aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:01:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:19:44 +0000
commit06943a7642e94d56633bec4871d7abc062f71c3e (patch)
treee105f79e3f3adb15ed5ef193c67869d9ba9c56cb
parent37364439a808eb615da5f42e7236903c119b60ca (diff)
downloadports-06943a7642e94d56633bec4871d7abc062f71c3e.tar.gz
ports-06943a7642e94d56633bec4871d7abc062f71c3e.zip
devel/py-testpath: Update to 0.6.0
- Update version requirement of TEST_DEPENDS - Update do-test: Changes: https://github.com/jupyter/testpath/blob/master/doc/history.rst
-rw-r--r--devel/py-testpath/Makefile9
-rw-r--r--devel/py-testpath/distinfo6
-rw-r--r--devel/py-testpath/files/setup.py25
3 files changed, 34 insertions, 6 deletions
diff --git a/devel/py-testpath/Makefile b/devel/py-testpath/Makefile
index c0febb10324e..93ec44b1b3fd 100644
--- a/devel/py-testpath/Makefile
+++ b/devel/py-testpath/Makefile
@@ -1,5 +1,5 @@
PORTNAME= testpath
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,14 +10,17 @@ COMMENT= Test utilities for Python code working with files and commands
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
do-test:
- @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER})
+ cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} -m pytest -rs -v
.include <bsd.port.mk>
diff --git a/devel/py-testpath/distinfo b/devel/py-testpath/distinfo
index bbdb81b99dc5..7c866a622f41 100644
--- a/devel/py-testpath/distinfo
+++ b/devel/py-testpath/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1624630220
-SHA256 (testpath-0.5.0.tar.gz) = 1acf7a0bcd3004ae8357409fc33751e16d37ccc650921da1094a86581ad1e417
-SIZE (testpath-0.5.0.tar.gz) = 94021
+TIMESTAMP = 1649423978
+SHA256 (testpath-0.6.0.tar.gz) = 2f1b97e6442c02681ebe01bd84f531028a7caea1af3825000f52345c30285e0f
+SIZE (testpath-0.6.0.tar.gz) = 93348
diff --git a/devel/py-testpath/files/setup.py b/devel/py-testpath/files/setup.py
new file mode 100644
index 000000000000..b7ed5d66b73c
--- /dev/null
+++ b/devel/py-testpath/files/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['testpath']
+
+package_data = \
+{'': ['*']}
+
+extras_require = \
+{'test': ['pytest']}
+
+setup(name='testpath',
+ version='%%PORTVERSION%%',
+ description='Test utilities for code working with files and commands',
+ author=None,
+ author_email='Jupyter Development Team <jupyter@googlegroups.com>',
+ url=None,
+ packages=packages,
+ package_data=package_data,
+ extras_require=extras_require,
+ python_requires='>= 3.5',
+ )