aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2022-10-24 19:09:23 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-10-24 19:09:23 +0000
commit06b53a2e9d8049ea97dc24094fd18b1cb77cf053 (patch)
tree58383a4cdbeba5b8d68452f13169a25a2be8a8f2
parent08a9700c0ab9193e4da0456f2adb3c067e9f7647 (diff)
downloadports-06b53a2e9d8049ea97dc24094fd18b1cb77cf053.tar.gz
ports-06b53a2e9d8049ea97dc24094fd18b1cb77cf053.zip
devel/py-nbconvert: Update to 7.2.2
And add a workaround to install templates to fix `jupyter nbconvert` command. [1] PR: 267212 [1] Reported by: p5B2EA84B3@t-online.de [1]
-rw-r--r--devel/py-nbconvert/Makefile6
-rw-r--r--devel/py-nbconvert/distinfo6
-rw-r--r--devel/py-nbconvert/pkg-plist47
3 files changed, 55 insertions, 4 deletions
diff --git a/devel/py-nbconvert/Makefile b/devel/py-nbconvert/Makefile
index a153c8724eda..e7498bfa196f 100644
--- a/devel/py-nbconvert/Makefile
+++ b/devel/py-nbconvert/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nbconvert
-PORTVERSION= 7.2.1
+PORTVERSION= 7.2.2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -41,4 +41,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6:devel/py-importlib-
post-patch:
@${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/jupyter/nbconvert
+ cd ${WRKSRC}/share && ${COPYTREE_SHARE} templates ${STAGEDIR}${PREFIX}/share/jupyter/nbconvert
+
.include <bsd.port.post.mk>
diff --git a/devel/py-nbconvert/distinfo b/devel/py-nbconvert/distinfo
index fc7e9504b5ff..aefbc5d9d3f4 100644
--- a/devel/py-nbconvert/distinfo
+++ b/devel/py-nbconvert/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665330706
-SHA256 (nbconvert-7.2.1.tar.gz) = 1e180801205ad831b6e2480c5a03307dfb6327fa5b2f9b156d6fed45f9700686
-SIZE (nbconvert-7.2.1.tar.gz) = 731368
+TIMESTAMP = 1666626189
+SHA256 (nbconvert-7.2.2.tar.gz) = 24acfaa466d2c9b7eb524800e4a45afbed862c5d058cfb30fc7aa24d448c95eb
+SIZE (nbconvert-7.2.2.tar.gz) = 818074
diff --git a/devel/py-nbconvert/pkg-plist b/devel/py-nbconvert/pkg-plist
new file mode 100644
index 000000000000..58242357e36d
--- /dev/null
+++ b/devel/py-nbconvert/pkg-plist
@@ -0,0 +1,47 @@
+share/jupyter/nbconvert/templates/asciidoc/conf.json
+share/jupyter/nbconvert/templates/asciidoc/index.asciidoc.j2
+share/jupyter/nbconvert/templates/base/celltags.j2
+share/jupyter/nbconvert/templates/base/display_priority.j2
+share/jupyter/nbconvert/templates/base/jupyter_widgets.html.j2
+share/jupyter/nbconvert/templates/base/mathjax.html.j2
+share/jupyter/nbconvert/templates/base/null.j2
+share/jupyter/nbconvert/templates/basic/conf.json
+share/jupyter/nbconvert/templates/basic/index.html.j2
+share/jupyter/nbconvert/templates/classic/base.html.j2
+share/jupyter/nbconvert/templates/classic/conf.json
+share/jupyter/nbconvert/templates/classic/index.html.j2
+share/jupyter/nbconvert/templates/compatibility/display_priority.tpl
+share/jupyter/nbconvert/templates/compatibility/full.tpl
+share/jupyter/nbconvert/templates/lab/base.html.j2
+share/jupyter/nbconvert/templates/lab/conf.json
+share/jupyter/nbconvert/templates/lab/index.html.j2
+share/jupyter/nbconvert/templates/lab/static/index.css
+share/jupyter/nbconvert/templates/lab/static/theme-dark.css
+share/jupyter/nbconvert/templates/lab/static/theme-light.css
+share/jupyter/nbconvert/templates/latex/base.tex.j2
+share/jupyter/nbconvert/templates/latex/conf.json
+share/jupyter/nbconvert/templates/latex/display_priority.j2
+share/jupyter/nbconvert/templates/latex/document_contents.tex.j2
+share/jupyter/nbconvert/templates/latex/index.tex.j2
+share/jupyter/nbconvert/templates/latex/null.j2
+share/jupyter/nbconvert/templates/latex/report.tex.j2
+share/jupyter/nbconvert/templates/latex/style_bw_ipython.tex.j2
+share/jupyter/nbconvert/templates/latex/style_bw_python.tex.j2
+share/jupyter/nbconvert/templates/latex/style_ipython.tex.j2
+share/jupyter/nbconvert/templates/latex/style_jupyter.tex.j2
+share/jupyter/nbconvert/templates/latex/style_python.tex.j2
+share/jupyter/nbconvert/templates/markdown/conf.json
+share/jupyter/nbconvert/templates/markdown/index.md.j2
+share/jupyter/nbconvert/templates/python/conf.json
+share/jupyter/nbconvert/templates/python/index.py.j2
+share/jupyter/nbconvert/templates/reveal/base.html.j2
+share/jupyter/nbconvert/templates/reveal/cellslidedata.j2
+share/jupyter/nbconvert/templates/reveal/conf.json
+share/jupyter/nbconvert/templates/reveal/index.html.j2
+share/jupyter/nbconvert/templates/reveal/static/custom_reveal.css
+share/jupyter/nbconvert/templates/rst/conf.json
+share/jupyter/nbconvert/templates/rst/index.rst.j2
+share/jupyter/nbconvert/templates/script/conf.json
+share/jupyter/nbconvert/templates/script/script.j2
+share/jupyter/nbconvert/templates/webpdf/conf.json
+share/jupyter/nbconvert/templates/webpdf/index.pdf.j2