aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-02-22 08:02:41 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-02-22 09:22:11 +0000
commit06b726b8186948d6c0869a0669bc0405ee12b3e1 (patch)
tree3d81849d2e504db9cfa8abf71773ec8a71516522
parentea2f77f9dfc9f7979b4daee816ca328a20018ae0 (diff)
downloadports-06b726b8186948d6c0869a0669bc0405ee12b3e1.tar.gz
ports-06b726b8186948d6c0869a0669bc0405ee12b3e1.zip
www/gitlab-ce: fix regression from 6b48a4fbbed1d124465aa72606b03e6ab559817c
-rw-r--r--www/gitlab-ce/Makefile4
-rw-r--r--www/gitlab-ce/files/patch-Gemfile9
2 files changed, 11 insertions, 2 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 6ad64fef40a6..619d7f2fd843 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gitlab-ce
PORTVERSION= 16.8.3
-PORTREVISION= 2
+PORTREVISION= 3
DISTVERSIONPREFIX= v
CATEGORIES= www devel
@@ -112,7 +112,7 @@ MY_DEPENDS= git>=2.41.0:devel/git \
rubygem-gitlab-fog-azure-rm>=1.8.0<1.9:net/rubygem-gitlab-fog-azure-rm \
rubygem-google-apis-storage_v1>=0.29<1:devel/rubygem-google-apis-storage_v1 \
rubygem-google-cloud-storage145>=1.45.0<1.46:net/rubygem-google-cloud-storage145 \
- rubygem-google-apis-core011>=0.11.2<0.12:devel/rubygem-google-apis-core011 \
+ rubygem-google-apis-core>=0.11.2<2:devel/rubygem-google-apis-core \
rubygem-google-apis-compute_v1_057>=0.57.0<0.58:devel/rubygem-google-apis-compute_v1_057 \
rubygem-google-apis-container_v1>=0.43.0<0.44:devel/rubygem-google-apis-container_v1 \
rubygem-google-apis-container_v1beta1>=0.43.0<0.44:devel/rubygem-google-apis-container_v1beta1 \
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index e950aad1385d..19f968ceecac 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -29,6 +29,15 @@
gem 'omniauth-salesforce', '~> 1.0.5', path: 'vendor/gems/omniauth-salesforce' # See gem README.md # rubocop:todo Gemfile/MissingFeatureCategory
gem 'omniauth-atlassian-oauth2', '~> 0.2.0' # rubocop:todo Gemfile/MissingFeatureCategory
gem 'rack-oauth2', '~> 1.21.3' # rubocop:todo Gemfile/MissingFeatureCategory
+@@ -185,7 +185,7 @@ gem 'gitlab-fog-azure-rm', '~> 1.8.0', require: 'fog/a
+ gem 'google-apis-storage_v1', '~> 0.29' # rubocop:todo Gemfile/MissingFeatureCategory
+ gem 'google-cloud-storage', '~> 1.45.0' # rubocop:todo Gemfile/MissingFeatureCategory
+ # We need >= 0.11.1 because that's when match_glob support is added to list_objects
+-gem 'google-apis-core', '~> 0.11.0', '>= 0.11.1' # rubocop:todo Gemfile/MissingFeatureCategory
++gem 'google-apis-core', '~> 0.11', '>= 0.11.1' # rubocop:todo Gemfile/MissingFeatureCategory
+ gem 'google-apis-compute_v1', '~> 0.57.0' # rubocop:todo Gemfile/MissingFeatureCategory
+ gem 'google-apis-container_v1', '~> 0.43.0' # rubocop:todo Gemfile/MissingFeatureCategory
+ gem 'google-apis-container_v1beta1', '~> 0.43.0' # rubocop:todo Gemfile/MissingFeatureCategory
@@ -203,9 +203,9 @@ gem 'seed-fu', '~> 2.3.7' # rubocop:todo Gemfile/Missi
gem 'elasticsearch-model', '~> 7.2' # rubocop:todo Gemfile/MissingFeatureCategory
gem 'elasticsearch-rails', '~> 7.2', require: 'elasticsearch/rails/instrumentation' # rubocop:todo Gemfile/MissingFeatureCategory