aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 00:36:58 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 00:36:58 +0000
commit06c9e2951924e6ff2357d8f507dc977c957c8988 (patch)
tree0fad8a9ca85dd3800b61870d587d859e0c40e9f2
parente6ffc0453c74f48031c7820db5dc43018e043151 (diff)
downloadports-06c9e2951924e6ff2357d8f507dc977c957c8988.tar.gz
ports-06c9e2951924e6ff2357d8f507dc977c957c8988.zip
devel/py-pytest-doctestplus: Add py-pytest-doctestplus 1.2.1
pytest-doctestplus contains a plugin for the pytest framework that provides advanced doctest support and enables the testing of various text files, such as reStructuredText (".rst"), markdown (".md"), and TeX (".tex").
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-doctestplus/Makefile26
-rw-r--r--devel/py-pytest-doctestplus/distinfo3
-rw-r--r--devel/py-pytest-doctestplus/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c35e7bca0246..ec31a3add8b0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5427,6 +5427,7 @@
SUBDIR += py-pytest-cpp
SUBDIR += py-pytest-datadir
SUBDIR += py-pytest-django
+ SUBDIR += py-pytest-doctestplus
SUBDIR += py-pytest-drop-dup-tests
SUBDIR += py-pytest-enabler
SUBDIR += py-pytest-env
diff --git a/devel/py-pytest-doctestplus/Makefile b/devel/py-pytest-doctestplus/Makefile
new file mode 100644
index 000000000000..24e2552f1ecd
--- /dev/null
+++ b/devel/py-pytest-doctestplus/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= pytest-doctestplus
+PORTVERSION= 1.2.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pytest plugin with advanced doctest features
+WWW= https://github.com/scientific-python/pytest-doctestplus
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=30.3.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=17.0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=4.6,1:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=30.3.0:devel/py-setuptools@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-doctestplus/distinfo b/devel/py-pytest-doctestplus/distinfo
new file mode 100644
index 000000000000..e503a05a5454
--- /dev/null
+++ b/devel/py-pytest-doctestplus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1712084450
+SHA256 (pytest-doctestplus-1.2.1.tar.gz) = 2472a8a2c8cea34d2f65f6499543faeb748eecb59c597852fd98839b47307679
+SIZE (pytest-doctestplus-1.2.1.tar.gz) = 45896
diff --git a/devel/py-pytest-doctestplus/pkg-descr b/devel/py-pytest-doctestplus/pkg-descr
new file mode 100644
index 000000000000..ee16faea2d53
--- /dev/null
+++ b/devel/py-pytest-doctestplus/pkg-descr
@@ -0,0 +1,3 @@
+pytest-doctestplus contains a plugin for the pytest framework that provides
+advanced doctest support and enables the testing of various text files, such as
+reStructuredText (".rst"), markdown (".md"), and TeX (".tex").