aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-21 20:44:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-21 20:48:11 +0000
commit076ddf2c24ed915fab42cba84fe9fe206e90ddf8 (patch)
treeceb9f79d22d443425628e77f9824934749da6be0
parent03f99553aea5fe2054dda87277a9899c3c3a652b (diff)
downloadports-076ddf2c24ed915fab42cba84fe9fe206e90ddf8.tar.gz
ports-076ddf2c24ed915fab42cba84fe9fe206e90ddf8.zip
net/geoipupdate: Sanitize MANPREFIX
Approved by: portmgr (blanket)
-rw-r--r--net/geoipupdate/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net/geoipupdate/Makefile b/net/geoipupdate/Makefile
index 8e36c2a0b2f7..f692e98aa404 100644
--- a/net/geoipupdate/Makefile
+++ b/net/geoipupdate/Makefile
@@ -1,5 +1,6 @@
PORTNAME= geoipupdate
PORTVERSION= 6.1.0
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= net geography
@@ -24,8 +25,8 @@ OPTIONS_DEFINE= DOCS MANPAGES
OPTIONS_DEFAULT=MANPAGES
MANPAGES_BUILD_DEPENDS= lowdown:textproc/lowdown
-MANPAGES_PLIST_FILES= man/man1/geoipupdate.1.gz \
- man/man5/GeoIP.conf.5.gz
+MANPAGES_PLIST_FILES= share/man/man1/geoipupdate.1.gz \
+ share/man/man5/GeoIP.conf.5.gz
PLIST_FILES= bin/geoipupdate \
'@sample etc/GeoIP.conf.sample' \
@@ -52,8 +53,8 @@ do-install-DOCS-on:
cd ${WRKSRC}/build && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
do-install-MANPAGES-on:
- ${INSTALL_MAN} ${WRKSRC}/build/geoipupdate.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/build/GeoIP.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/build/geoipupdate.1 ${STAGEDIR}${PREFIX}/share/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/build/GeoIP.conf.5 ${STAGEDIR}${PREFIX}/share/man/man5
do-test:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GO_ENV} GOPROXY=off ${GO_CMD} test ${GO_TESTFLAGS} ./...