aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 18:59:33 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 19:34:41 +0000
commit07902a1172a1f729af65dd0e115d09683b2b01c1 (patch)
tree955895cad5ae084115cc5efc1ea36c250e5062ba
parent45c9ee77bf78aec4c4f078dffab74ae6555186ae (diff)
downloadports-07902a1172a1f729af65dd0e115d09683b2b01c1.tar.gz
ports-07902a1172a1f729af65dd0e115d09683b2b01c1.zip
comms/qico: Fix build with llvm16
- Utilize OPTIONSNG where applicable - Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--comms/qico/Makefile50
-rw-r--r--comms/qico/pkg-plist3
2 files changed, 27 insertions, 26 deletions
diff --git a/comms/qico/Makefile b/comms/qico/Makefile
index 7676ce58d1f5..153128c9eb1e 100644
--- a/comms/qico/Makefile
+++ b/comms/qico/Makefile
@@ -9,52 +9,50 @@ LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= autoreconf
-GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= kosfango
GH_TAGNAME= 15673bf
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-config=${CONFDIR}/qico.conf \
+ --with-default-speed=115200
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFLICTS_INSTALL= qcc # bin/qcc
+
+PLIST_SUB= QBASEDIR=${QBASEDIR} QLOGDIR=${QLOGDIR}
+
CONFDIR?= ${PREFIX}/etc/fido/qico
QBASEDIR?= /var/spool/fido/qico
QLOGDIR?= /var/log/fido/qico
-PLIST_SUB= QBASEDIR=${QBASEDIR} QLOGDIR=${QLOGDIR}
.if defined(WITH_OPENLOCK)
CONFIGURE_ARGS+= --with-lock-style=open
.endif
-CONFIGURE_ARGS+= --with-config=${CONFDIR}/qico.conf \
- --with-default-speed=115200
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-CONFLICTS_INSTALL= qcc # bin/qcc
DOCS= Changes FAQ README
EXAMPLES= koi8r_866.cp onchat qhistory qico.xpm qlinks sfreq \
stat.run synctime test.pl tossing
MANS= qcc.8 qctl.8 qico.8
+
OPTIONS_DEFINE= QCC PERL HYDRA
-QCC_DESC= Build Qico control center (qcc)
-PERL_DESC= Enable Perl-hooks support
-HYDRA_DESC= Enable Hydra 4K/8K/16K protocol extensions
OPTIONS_DEFAULT= PERL QCC
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+HYDRA_DESC= Enable Hydra 4K/8K/16K protocol extensions
+PERL_DESC= Enable Perl-hooks support
+QCC_DESC= Build Qico control center (qcc)
-.if !${PORT_OPTIONS:MQCC}
-CONFIGURE_ARGS+=--disable-qcc
-PLIST_SUB+= QCC="@comment "
-.else
-PLIST_SUB+= QCC=""
-.endif
+HYDRA_CONFIGURE_ON=--enable-hydra8k
+PERL_CONFIGURE_ON=--enable-perl
+PERL_USES= perl5
+QCC_CONFIGURE_OFF=--disable-qcc
-.if ${PORT_OPTIONS:MPERL}
-CONFIGURE_ARGS+=--enable-perl
-USES+= perl5
-.endif
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MHYDRA}
-CONFIGURE_ARGS+=--enable-hydra8k
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
do-install:
@@ -65,9 +63,6 @@ do-install:
${MKDIR} ${STAGEDIR}${CONFDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/qico ${STAGEDIR}${PREFIX}/sbin/
${INSTALL_PROGRAM} ${WRKSRC}/src/qctl ${STAGEDIR}${PREFIX}/bin/
-.if ${PORT_OPTIONS:MQCC}
- ${INSTALL_PROGRAM} ${WRKSRC}/src/qcc ${STAGEDIR}${PREFIX}/bin/
-.endif
${INSTALL_DATA} ${WRKSRC}/qico.conf.sample ${STAGEDIR}${CONFDIR}/qico.conf.sample
${INSTALL_DATA} ${WRKSRC}/qico.substs.sample ${STAGEDIR}${CONFDIR}/qico.substs.sample
${INSTALL_DATA} ${WRKSRC}/qico.passwd.sample ${STAGEDIR}${CONFDIR}/qico.passwd.sample
@@ -83,4 +78,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/${i} ${STAGEDIR}${PREFIX}/man/man8/${i}
.endfor
+do-install-QCC-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/qcc ${STAGEDIR}${PREFIX}/bin/
+
.include <bsd.port.mk>
diff --git a/comms/qico/pkg-plist b/comms/qico/pkg-plist
index fb6a4f569d90..ecf7a48dd11b 100644
--- a/comms/qico/pkg-plist
+++ b/comms/qico/pkg-plist
@@ -29,3 +29,6 @@ bin/qctl
man/man8/qctl.8.gz
man/man8/qico.8.gz
sbin/qico
+@dir /var/log/fido
+@dir %%QBASEDIR%%
+@dir /var/spool/fido