aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-11-07 17:32:58 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-11-07 20:31:18 +0000
commit07a268e13eec4760331e745eb90bd076ab243e58 (patch)
treef75a29cf5720222dda034fee82afcc5a066d3b83
parentbe0074a975df30396ea695a90f7efe23d690aa11 (diff)
downloadports-07a268e13eec4760331e745eb90bd076ab243e58.tar.gz
ports-07a268e13eec4760331e745eb90bd076ab243e58.zip
emulators/yuzu: avoid gcc* dep via shlib_required after 4021ff7b85d9
Error: /usr/local/bin/yuzu is linked to /usr/local/lib/gcc11/libgcc_s.so.1 from lang/gcc11 but it is not declared as a dependency (cherry picked from commit 64c2cc440f5882a61fc5a13f4f1d4a0216946698)
-rw-r--r--emulators/yuzu/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index fc0eeeda2698..628f19b1158d 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,6 +1,6 @@
PORTNAME= yuzu
PORTVERSION= s20220721
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
.if make(makesum)
MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb
@@ -64,7 +64,7 @@ CMAKE_ON+= BUNDLE_SPEEX # only used by cubeb tests
CMAKE_OFF= YUZU_USE_BUNDLED_OPUS YUZU_USE_EXTERNAL_SDL2 ENABLE_GNUTLS ENABLE_MBEDTLS
CMAKE_OFF+= ${CMAKE_TESTING_ON}
CMAKE_TESTING_ON= YUZU_TESTS
-LDFLAGS+= -static-libstdc++ # avoid libc++ conflict, requires files/patch-fmt
+LDFLAGS+= -static-libstdc++ -static-libgcc # avoid libc++ conflict, requires files/patch-fmt
LDFLAGS+= -Wl,--as-needed # Qt5Network
ELF_FEATURES= ${PLIST_FILES:Mbin/*:S/^/+wxneeded:/}
PLIST_FILES= bin/${PORTNAME}-cmd