aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-08 19:04:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-08 19:04:44 +0000
commit07ca8a486f688fc2f042b81a2339ceb6d7e99e32 (patch)
treeaace53ce1b4af8c6fb02b604358fcc634c961f7d
parentaee0b60bdc065feaa727fcfb79f457d6e8eb30e8 (diff)
downloadports-07ca8a486f688fc2f042b81a2339ceb6d7e99e32.tar.gz
ports-07ca8a486f688fc2f042b81a2339ceb6d7e99e32.zip
cad/nvc: Fix dependency on devel/libunwind
It is needed only when ${OSVERSION} < 1400052. Reported by: fallout
-rw-r--r--cad/nvc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/cad/nvc/Makefile b/cad/nvc/Makefile
index a217d797808a..ef004c944c10 100644
--- a/cad/nvc/Makefile
+++ b/cad/nvc/Makefile
@@ -9,8 +9,7 @@ COMMENT= VHDL compiler and simulator
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= llvm-config${LLVM_VERSION}:devel/llvm${LLVM_VERSION} \
- ${LOCALBASE}/include/unwind.h:devel/libunwind
+BUILD_DEPENDS= llvm-config${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
RUN_DEPENDS= llvm${LLVM_VERSION}>0:devel/llvm${LLVM_VERSION}
TEST_DEPENDS= check>0:devel/check
@@ -31,6 +30,12 @@ MAKE_ARGS= CFLAGS="${CFLAGS}" # only for tests
LLVM_VERSION= ${LLVM_DEFAULT}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1400052 # devel/libunwind installs include/unwind.h only before that version, after which it probably exists in the base
+BUILD_DEPENDS+= ${LOCALBASE}/include/unwind.h:devel/libunwind
+.endif
+
post-install:
${FIND} ${STAGEDIR}${PREFIX} -name "*.so" | ${XARGS} ${STRIP_CMD}