aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Bischoff <marcel@herrbischoff.com>2022-12-20 12:08:01 +0000
committerRonald Klop <ronald@FreeBSD.org>2022-12-22 19:34:07 +0000
commit07e39d15a1c2589b2103f58aaaa6dd1640c2f7a8 (patch)
tree3523ab97012d10ea1bf380cf200e5795a97083ca
parent68bafed5be88f21f0de744f0bb3c858ce086acda (diff)
downloadports-07e39d15a1c2589b2103f58aaaa6dd1640c2f7a8.tar.gz
ports-07e39d15a1c2589b2103f58aaaa6dd1640c2f7a8.zip
news/nzbhydra2: update to v4.7.4
Summary: - Add environment variable to suppress update dialog - Update JDK to v17 to satisfy future requirement - Maintainer change - Remove build leftover Changes: https://github.com/theotherp/nzbhydra2/blob/v4.7.4/changelog.md PR: 268430 Approved by: pkubaj (mentor) Differential Revision: https://reviews.freebsd.org/D37782
-rw-r--r--news/nzbhydra2/Makefile10
-rw-r--r--news/nzbhydra2/distinfo6
-rw-r--r--news/nzbhydra2/files/nzbhydra2.in1
3 files changed, 11 insertions, 6 deletions
diff --git a/news/nzbhydra2/Makefile b/news/nzbhydra2/Makefile
index 64c70e61ef38..18b85f92246b 100644
--- a/news/nzbhydra2/Makefile
+++ b/news/nzbhydra2/Makefile
@@ -1,10 +1,10 @@
PORTNAME= nzbhydra2
-DISTVERSION= 4.7.2
+DISTVERSION= 4.7.4
DISTVERSIONSUFFIX= -linux
CATEGORIES= news java
MASTER_SITES= https://github.com/theotherp/${PORTNAME}/releases/download/v${DISTVERSION}/
-MAINTAINER= daniel@shafer.cc
+MAINTAINER= marcel@herrbischoff.com
COMMENT= Usenet meta search
WWW= https://github.com/theotherp/nzbhydra2
@@ -24,7 +24,7 @@ SUB_FILES= nzbhydra2
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
JAVA=${JAVA}
-JAVA_VERSION= 8+
+JAVA_VERSION= 17+
JAVA_VENDOR= openjdk
JAVA_RUN= yes
@@ -42,6 +42,10 @@ post-extract:
# Cleanup unnecessary files
@${RM} -r ${WRKSRC}/systemd ${WRKSRC}/sysv ${WRKSRC}/rc.d ${WRKSRC}/upstart ${WRKSRC}/nzbhydra2wrapper.py
+pre-install:
+ # temp fix for https://github.com/theotherp/nzbhydra2/issues/812
+ ${RM} -r ${WRKSRC}/data
+
do-install:
@${MKDIR} ${STAGEDIR}/${DATADIR}
${INSTALL} -d -m 755 ${STAGEDIR}/${DATADIR}
diff --git a/news/nzbhydra2/distinfo b/news/nzbhydra2/distinfo
index 95d660816b3c..14f3161ecf8a 100644
--- a/news/nzbhydra2/distinfo
+++ b/news/nzbhydra2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669893469
-SHA256 (nzbhydra2-4.7.2-linux.zip) = 3d3f281563e64d104a59b47ba337b7ee2ffcbdb0574cfd6874640f5ad3470ca5
-SIZE (nzbhydra2-4.7.2-linux.zip) = 83317938
+TIMESTAMP = 1671278127
+SHA256 (nzbhydra2-4.7.4-linux.zip) = 70ca65452f1e80f010a61bd5a760961efcab04e06cd0599403b174af753d8a84
+SIZE (nzbhydra2-4.7.4-linux.zip) = 83396533
diff --git a/news/nzbhydra2/files/nzbhydra2.in b/news/nzbhydra2/files/nzbhydra2.in
index ff4a9fa85df0..490cceb158c0 100644
--- a/news/nzbhydra2/files/nzbhydra2.in
+++ b/news/nzbhydra2/files/nzbhydra2.in
@@ -43,6 +43,7 @@ start_precmd=nzbhydra2_precmd
nzbhydra2_precmd()
{
export XDG_CONFIG_HOME=${nzbhydra2_data_dir}
+ export NZBHYDRA_DISABLE_UPDATE=1
if [ -f ${pidfile} ]; then
rm -f ${pidfile}