aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-09-27 10:00:48 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-09-27 10:00:48 +0000
commit080478034ac8ba6bf5cc2edc240385d8ad4c4048 (patch)
tree9425c731cf3f1ea8b33d9aefe73547488a85d65f
parenta309c1d095c60b47b1b88cc45999a4dd734d6038 (diff)
downloadports-080478034ac8ba6bf5cc2edc240385d8ad4c4048.tar.gz
ports-080478034ac8ba6bf5cc2edc240385d8ad4c4048.zip
editors/lite-xl: install some nonessential but nice to have files
Modern graphical environments usually give better user experience when programs are supplied with icon(s), .desktop file, etc. PR: 274077
-rw-r--r--editors/lite-xl/Makefile10
-rw-r--r--editors/lite-xl/pkg-plist3
2 files changed, 12 insertions, 1 deletions
diff --git a/editors/lite-xl/Makefile b/editors/lite-xl/Makefile
index e1935ce0dcf8..46fe66cea3d0 100644
--- a/editors/lite-xl/Makefile
+++ b/editors/lite-xl/Makefile
@@ -1,6 +1,7 @@
PORTNAME= lite-xl
PORTVERSION= 2.1.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= danfe@FreeBSD.org
@@ -12,7 +13,7 @@ LICENSE= MIT
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpcre2-8.so:devel/pcre2
-USES= lua:54 meson pkgconfig sdl
+USES= desktop-file-utils lua:54 meson pkgconfig sdl
USE_SDL= sdl2
USE_GITHUB= yes
@@ -29,6 +30,13 @@ post-install:
${STAGEDIR}${DATADIR}/plugins
${CP} -a ${WRKSRC_plugins}/plugins \
${STAGEDIR}${DATADIR}/plugins/extra
+ ${CP} -a ${WRKSRC}/resources/linux/org.lite_xl.lite_xl.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/metainfo
+ ${CP} -a ${WRKSRC}/resources/linux/org.lite_xl.lite_xl.appdata.xml \
+ ${STAGEDIR}${PREFIX}/share/metainfo
+ ${CP} -a ${WRKSRC}/resources/icons/lite-xl.svg \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/changelog.md ${STAGEDIR}${DOCSDIR}
diff --git a/editors/lite-xl/pkg-plist b/editors/lite-xl/pkg-plist
index b124e334b1f1..4aab730db0cb 100644
--- a/editors/lite-xl/pkg-plist
+++ b/editors/lite-xl/pkg-plist
@@ -1,4 +1,5 @@
bin/lite-xl
+share/applications/org.lite_xl.lite_xl.desktop
%%DATADIR%%/colors/abyss.lua
%%DATADIR%%/colors/betelgeuse.lua
%%DATADIR%%/colors/c0mfy.lua
@@ -271,3 +272,5 @@ bin/lite-xl
%%DATADIR%%/string.lua
%%DATADIR%%/system.lua
%%DATADIR%%/utf8extra.lua
+share/metainfo/org.lite_xl.lite_xl.appdata.xml
+share/pixmaps/lite-xl.svg