aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-10 06:47:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-10 06:50:00 +0000
commit08048de81898098ed193270870a9e12865f7b90a (patch)
tree42aacfb8475a77cdb4b15318543a5acaf899ce05
parent893f2c6a347c1e2061f4e5351eab008f48f66e73 (diff)
downloadports-08048de81898098ed193270870a9e12865f7b90a.tar.gz
ports-08048de81898098ed193270870a9e12865f7b90a.zip
New port: audio/mamba: Virtual MIDI keyboard
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mamba/Makefile35
-rw-r--r--audio/mamba/distinfo5
-rw-r--r--audio/mamba/pkg-descr4
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index c5942087e06a..8e13ec5d82ad 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -456,6 +456,7 @@
SUBDIR += madplay
SUBDIR += madronalib
SUBDIR += malint
+ SUBDIR += mamba
SUBDIR += mate-media
SUBDIR += mclk-lv2
SUBDIR += mctoolame-decoder
diff --git a/audio/mamba/Makefile b/audio/mamba/Makefile
new file mode 100644
index 000000000000..0ba1c730ee1a
--- /dev/null
+++ b/audio/mamba/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= mamba
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.1
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Virtual MIDI keyboard
+
+LICENSE= BSD0CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libfluidsynth.so:audio/fluidsynth \
+ libjack.so:audio/jack \
+ liblo.so:audio/liblo \
+ libsmf.so:audio/libsmf
+
+USES= compiler:c++11-lang desktop-file-utils gmake pkgconfig xorg
+USE_GNOME= cairo glib20 libsigc++20
+USE_XORG= x11
+USE_BINUTILS= yes # linking needs some GNU features, fails on 12 without this, see https://github.com/brummer10/GxPlugins.lv2/issues/9
+
+USE_GITHUB= yes
+GH_ACCOUNT= brummer10
+GH_PROJECT= Mamba
+GH_TUPLE= brummer10:libxputty:b00d05c:libxputty/libxputty
+
+PLIST_FILES= bin/mamba \
+ share/applications/Mamba.desktop \
+ share/pixmaps/Mamba.svg
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mamba
+
+.include <bsd.port.mk>
diff --git a/audio/mamba/distinfo b/audio/mamba/distinfo
new file mode 100644
index 000000000000..d6a41c508e63
--- /dev/null
+++ b/audio/mamba/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1618035292
+SHA256 (brummer10-Mamba-v2.1_GH0.tar.gz) = bdcff972d4ff6e0209bd21ca417d8a941939dd2137d0f715580e9caf5fb39470
+SIZE (brummer10-Mamba-v2.1_GH0.tar.gz) = 133940
+SHA256 (brummer10-libxputty-b00d05c_GH0.tar.gz) = 6935d613abba4a94782adb89a8322821921d53715ee282edf0c5661591942cd5
+SIZE (brummer10-libxputty-b00d05c_GH0.tar.gz) = 496688
diff --git a/audio/mamba/pkg-descr b/audio/mamba/pkg-descr
new file mode 100644
index 000000000000..562139512580
--- /dev/null
+++ b/audio/mamba/pkg-descr
@@ -0,0 +1,4 @@
+Mamba is a virtual Midi keyboard and Midi live looper for Jack Audio Connection
+Kit.
+
+WWW: https://github.com/brummer10/Mamba