aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuane <parakleta@darkreality.org>2023-09-22 19:39:29 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-24 18:57:14 +0000
commit0816318fd77ec41759affa9e42aac2a2603186a1 (patch)
tree43a1d53cb025946c99505f956c0730df39c206e6
parent9e5e541baf9c3cc722ad2f933cf5ad3576c0333b (diff)
downloadports-0816318fd77ec41759affa9e42aac2a2603186a1.tar.gz
ports-0816318fd77ec41759affa9e42aac2a2603186a1.zip
x11-wm/compton: use basic regex for compton-trans
The compton-trans script makes use of extended regex features sed(1) does not support. Patch it to use BREs only. While we are at it, do some housekeeping on the port Makefile. PR: 273319 Approved by: femc7488@gmail.com (maintainer timeout)
-rw-r--r--x11-wm/compton/Makefile7
-rw-r--r--x11-wm/compton/files/patch-bin_compton-trans60
2 files changed, 63 insertions, 4 deletions
diff --git a/x11-wm/compton/Makefile b/x11-wm/compton/Makefile
index 399d0c34e811..44abcce8f0b5 100644
--- a/x11-wm/compton/Makefile
+++ b/x11-wm/compton/Makefile
@@ -1,6 +1,6 @@
PORTNAME= compton
-PORTVERSION= 20160907
-PORTREVISION= 6
+DISTVERSION= 20160907
+PORTREVISION= 7
CATEGORIES= x11-wm
MAINTAINER= femc7488@gmail.com
@@ -13,11 +13,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= xprop:x11/xprop \
xwininfo:x11/xwininfo
+USES= gmake pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= chjj
GH_TAGNAME= b7f43ee
-
-USES= gmake pkgconfig xorg
USE_XORG= x11 xcomposite xdamage xext xfixes xrandr xrender
MAKE_ARGS= COMPTON_VERSION=git-${PORTVERSION}-${GH_TAGNAME} \
diff --git a/x11-wm/compton/files/patch-bin_compton-trans b/x11-wm/compton/files/patch-bin_compton-trans
new file mode 100644
index 000000000000..db6b7d7eee0d
--- /dev/null
+++ b/x11-wm/compton/files/patch-bin_compton-trans
@@ -0,0 +1,60 @@
+--- bin/compton-trans.orig 2016-09-07 08:23:44 UTC
++++ bin/compton-trans
+@@ -2,7 +2,7 @@
+
+ #
+ # compton-trans
+-# transset in a bash script
++# transset in a sh script
+ # Copyright (c) 2011-2012, Christopher Jeffrey
+ #
+
+@@ -46,7 +46,7 @@ v=
+
+ # Workaround: replace '-5' with '~5' so as not to confuse getopts.
+ for v in "$@"; do
+- shift && set -- "$@" "$(echo "$v" | sed 's/^-\([0-9]\+%\?\)$/~\1/')"
++ shift && set -- "$@" "$(echo "$v" | sed 's/^-\([0-9]\{1,\}%\{0,1\}\)$/~\1/')"
+ done
+
+ # This takes into account the fact that getopts stops on
+@@ -69,7 +69,7 @@ while test $# -gt 0; do
+ OPTIND=$((OPTIND + 1))
+ ;;
+ name=* | window=* | opacity=*)
+- v=$(echo "$OPTARG" | sed 's/^[^=]\+=//')
++ v=$(echo "$OPTARG" | sed 's/^[^=]\{1,\}=//')
+ ;;
+ *)
+ echo "$0: illegal option $OPTARG" >& 2
+@@ -92,7 +92,7 @@ while test $# -gt 0; do
+ n) wprefix='-name'; window=$OPTARG ;;
+ w) wprefix='-id'; window=$OPTARG ;;
+ o) opacity=$OPTARG ;;
+- \?) exit 1 ;;
++ \{0,1\}) exit 1 ;;
+ esac
+ done
+
+@@ -102,10 +102,10 @@ while test $# -gt 0; do
+ done
+
+ # clean up opacity. xargs == a poor man's trim.
+-opacity=$(echo "$opacity" | xargs | sed 's/%//g' | sed 's/^~\([0-9]\+\)$/-\1/')
++opacity=$(echo "$opacity" | xargs | sed 's/%//g' | sed 's/^~\([0-9]\{1,\}\)$/-\1/')
+
+ # Validate opacity value
+-if test -z "$action" && ! echo "$opacity" | grep -q '^[+-]\?[0-9]\+$'; then
++if test -z "$action" && ! echo "$opacity" | grep -q '^[+-]\{0,1\}[0-9]\{1,\}$'; then
+ echo "Invalid opacity specified: $opacity."
+ exit 1
+ fi
+@@ -184,7 +184,7 @@ fi
+
+ # Get current opacity.
+ cur=$(xprop -id "$topmost" -notype _NET_WM_WINDOW_OPACITY \
+- | sed 's/^.*\b\([0-9]\+\).*$\|^.*$/\1/')
++ | sed -n 's/^\(.*^[_[:alnum:]]\)\{0,1\}\([0-9]\{1,\}\).*$/\2/p')
+ test -z "$cur" && cur=0xffffffff
+ cur=$((cur * 100 / 0xffffffff))
+