aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-21 06:20:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-21 06:21:14 +0000
commit089d935ab16b1ed209b2820c1652f38e023e1d6e (patch)
tree03b09c451e4c6d35aa90db6d5260d7fbc9764498
parent0c83b298845067c3796a26fa33a45f97d1703e94 (diff)
downloadports-089d935ab16b1ed209b2820c1652f38e023e1d6e.tar.gz
ports-089d935ab16b1ed209b2820c1652f38e023e1d6e.zip
multimedia/musikcube: Fix build on 13+ by properly linking to base OpenSSL
Reported by: fallout
-rw-r--r--multimedia/musikcube/Makefile2
-rw-r--r--multimedia/musikcube/files/patch-src_musikcube_CMakeLists.txt23
2 files changed, 25 insertions, 0 deletions
diff --git a/multimedia/musikcube/Makefile b/multimedia/musikcube/Makefile
index cf501924f87b..bbbb2b3d035b 100644
--- a/multimedia/musikcube/Makefile
+++ b/multimedia/musikcube/Makefile
@@ -34,10 +34,12 @@ GH_ACCOUNT= clangen
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1300079
USES+= ncurses
CMAKE_ARGS= -DNCURSES_DISABLE_LIB_SUFFIXES=false
+CMAKE_ON= FREEBSD_USE_BASE_NCURSES
.else
USES+= ncurses:port
CFLAGS+= -I${LOCALBASE}/include/ncurses
CMAKE_ARGS= -DNCURSES_DISABLE_LIB_SUFFIXES=true
+CMAKE_OFF= FREEBSD_USE_BASE_NCURSES
.endif
.include <bsd.port.mk>
diff --git a/multimedia/musikcube/files/patch-src_musikcube_CMakeLists.txt b/multimedia/musikcube/files/patch-src_musikcube_CMakeLists.txt
new file mode 100644
index 000000000000..db22da097189
--- /dev/null
+++ b/multimedia/musikcube/files/patch-src_musikcube_CMakeLists.txt
@@ -0,0 +1,23 @@
+--- src/musikcube/CMakeLists.txt.orig 2021-04-21 04:51:30 UTC
++++ src/musikcube/CMakeLists.txt
+@@ -103,10 +103,18 @@ if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
+ else()
+ find_package(PkgConfig)
+ if (${NCURSES_DISABLE_LIB_SUFFIXES} MATCHES "true")
+- pkg_check_modules(NCURSES REQUIRED ncurses panel)
++ if (FREEBSD_USE_BASE_NCURSES)
++ set(NCURSES_LIBRARIES ncurses panel)
++ else()
++ pkg_check_modules(NCURSES REQUIRED ncurses panel)
++ endif()
+ message(STATUS "[ncurses] using library names without 'w' prefix")
+ else()
+- pkg_check_modules(NCURSES REQUIRED ncursesw panelw)
++ if (FREEBSD_USE_BASE_NCURSES)
++ set(NCURSES_LIBRARIES ncursesw panelw)
++ else()
++ pkg_check_modules(NCURSES REQUIRED ncursesw panelw)
++ endif()
+ message(STATUS "[ncurses] using library names with 'w' prefix")
+ endif()
+ target_link_libraries(musikcube ${musikcube_LINK_LIBS} ${NCURSES_LIBRARIES} musikcore)