aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2024-01-25 04:41:27 +0000
committerKyle Evans <kevans@FreeBSD.org>2024-01-25 04:41:27 +0000
commit0932dd4166fdb17c0049a389e856352e5515b827 (patch)
treec01972e97e763ab12940721a51ee7a6813c635c4
parentcea6be3b48fa041c65b505f8383f86bfb15b6ad1 (diff)
downloadports-0932dd4166fdb17c0049a389e856352e5515b827.tar.gz
ports-0932dd4166fdb17c0049a389e856352e5515b827.zip
sysutils/orch: update to v0.2
Highlights: - Support for other platforms (Linux, macOS, NetBSD, OpenBSD) - Functionality pushed into lua modules, orch(1) is now a light driver on top of the library. The library's intended to be installed for use by other Lua scripts if desired, and exports `env` and `run_script(scriptfile, cfg)`. - More bits imported into the .orch script environment - stty() support to change some flags on the termios of the child - Support for Lua 5.2 was dropped The build system was rewritten in the interim to use cmake instead of bmake directly, so uidfix and related hacks have now disappeared. Makefile restructured slightly to appease portlint, and both EXAMPLES and MANPAGES options added to be able to disable those.
-rw-r--r--sysutils/orch/Makefile47
-rw-r--r--sysutils/orch/distinfo10
-rw-r--r--sysutils/orch/pkg-plist10
3 files changed, 21 insertions, 46 deletions
diff --git a/sysutils/orch/Makefile b/sysutils/orch/Makefile
index c599ec9e4dd2..eafd184730c6 100644
--- a/sysutils/orch/Makefile
+++ b/sysutils/orch/Makefile
@@ -1,9 +1,11 @@
PORTNAME= orch
-PORTVERSION= 0.1
-PORTREVISION= 1
+PORTVERSION= 0.2
CATEGORIES= sysutils
MASTER_SITES= https://git.kevans.dev/kevans/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
+PATCH_DIST_STRIP= -p1
+PATCH_SITES= https://git.kevans.dev/kevans/orch/commit/
+
MAINTAINER= kevans@FreeBSD.org
COMMENT= Program orchestration tool scripted with lua
WWW= https://git.kevans.dev/kevans/orch
@@ -11,42 +13,17 @@ WWW= https://git.kevans.dev/kevans/orch
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= lua:52-54 uidfix
+USES= cmake lua:53-54
-PATCH_DIST_STRIP= -p1
-PATCH_SITES= https://git.kevans.dev/kevans/orch/commit/
-# Add script dir to $PATH rather than some custom searching
-PATCHFILES+= b18ce0c42fc62e0e74a05cfd3286f664889b27d3.patch
-# Add a `make check` target for easier testing
-PATCHFILES+= 4d7797a706e57d1c7c6e0ed63c7bd86d4b0f2d71.patch
+OPTIONS_DEFINE= EXAMPLES MANPAGES
+OPTIONS_DEFAULT= EXAMPLES MANPAGES
+OPTIONS_SUB= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+EXAMPLES_CMAKE_BOOL= EXAMPLES
+MANPAGES_CMAKE_BOOL= MANPAGES
-ORCHLUA_PATH= ${PREFIX}/share/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV+= BINDIR="${PREFIX}/bin" \
- EXAMPLESDIR="${ORCHLUA_PATH}/examples" \
- MANDIR="${PREFIX}/share/man/man" \
- LUA_INCDIR="${LUA_INCDIR}" \
- LUA_LIB="-L${LUA_LIBDIR} -llua-${LUA_VER}" \
- ORCHLUA_PATH="${ORCHLUA_PATH}"
TEST_TARGET= check
-.include <bsd.port.pre.mk>
-
-# uidfix won't cover custom directories like this, so we'll hit it ourselves.
-.if ${UID} != 0
-MAKE_ENV+= FILESDIR_OWN=${UID} FILESDIR_GRP=${GID}
-MAKE_ENV+= EXAMPLESDIR_OWN=${UID} EXAMPLESDIR_GRP=${GID}
-.endif
-
-post-patch:
- # XXX This can go away in the next version; patch(1) won't take the hint of
- # the file mode from the patch, so we just fix it here in case one wants to
- # run the tests
- @${CHMOD} +x ${WRKSRC}/tests/my_cat
-
-pre-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/share/man/man1
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/orch/distinfo b/sysutils/orch/distinfo
index b7e9e5a50cfc..c54ce89aa79a 100644
--- a/sysutils/orch/distinfo
+++ b/sysutils/orch/distinfo
@@ -1,7 +1,3 @@
-TIMESTAMP = 1705682998
-SHA256 (orch-0.1.tar.gz) = c4c058f73324f883c9b823639664a97380bd041dbc4dfd646be325a99305aa64
-SIZE (orch-0.1.tar.gz) = 20134
-SHA256 (b18ce0c42fc62e0e74a05cfd3286f664889b27d3.patch) = 15ee1c5192b1336edfef0974ac8c3e5943a08e8049dba32b4547890595186e01
-SIZE (b18ce0c42fc62e0e74a05cfd3286f664889b27d3.patch) = 6865
-SHA256 (4d7797a706e57d1c7c6e0ed63c7bd86d4b0f2d71.patch) = c6577dae7b4c9e0dd2bf1e35a1a2c424cd7a1a5123dc09de3ccbafa7f5eec9f4
-SIZE (4d7797a706e57d1c7c6e0ed63c7bd86d4b0f2d71.patch) = 3320
+TIMESTAMP = 1706157383
+SHA256 (orch-0.2.tar.gz) = f08a375e7d610aad5b6c6fd4321492d546ae74cc27c37bbeeca5fe7268bbf8c9
+SIZE (orch-0.2.tar.gz) = 31909
diff --git a/sysutils/orch/pkg-plist b/sysutils/orch/pkg-plist
index 6fda20d6d435..1ed8bb0f16b2 100644
--- a/sysutils/orch/pkg-plist
+++ b/sysutils/orch/pkg-plist
@@ -1,5 +1,7 @@
bin/orch
-share/orch/examples/cat.orch
-share/orch/examples/nc.orch
-share/orch/orch.lua
-share/man/man1/orch.1.gz
+%%LUA_MODLIBDIR%%/orch/core.so
+%%LUA_MODSHAREDIR%%/orch.lua
+%%EXAMPLES%%%%EXAMPLESDIR%%/cat.orch
+%%EXAMPLES%%%%EXAMPLESDIR%%/nc.orch
+%%MANPAGES%%share/man/man1/orch.1.gz
+%%MANPAGES%%share/man/man5/orch.5.gz