aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2021-08-28 00:37:35 +0000
committerSteve Wills <swills@FreeBSD.org>2021-08-28 00:38:45 +0000
commit09a2cb4e55ea11a8a05cda65a5bc4223d565fe44 (patch)
treedd40fbddca033c0c823eee8c93ad60c76999f193
parentf865a62a34ca5b1b26ec6ac7da96cf2c0a2214a3 (diff)
downloadports-09a2cb4e55ea11a8a05cda65a5bc4223d565fe44.tar.gz
ports-09a2cb4e55ea11a8a05cda65a5bc4223d565fe44.zip
multimedia/mjpg-streamer: resurrect and update to new upstream
-rw-r--r--MOVED1
-rw-r--r--multimedia/mjpg-streamer/Makefile34
-rw-r--r--multimedia/mjpg-streamer/distinfo3
-rw-r--r--multimedia/mjpg-streamer/files/mjpg_streamer.in28
-rw-r--r--multimedia/mjpg-streamer/files/patch-mjpg__streamer.h10
-rw-r--r--multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_Makefile15
-rw-r--r--multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_input__testpicture.c11
-rw-r--r--multimedia/mjpg-streamer/files/patch-plugins_output__http_httpd.c23
-rw-r--r--multimedia/mjpg-streamer/files/patch-plugins_output__rtsp_output__rtsp.c10
-rw-r--r--multimedia/mjpg-streamer/files/patch-plugins_output__udp_output__udp.c10
-rw-r--r--multimedia/mjpg-streamer/files/patch-utils.c18
-rw-r--r--multimedia/mjpg-streamer/files/pkg-message.in14
-rw-r--r--multimedia/mjpg-streamer/pkg-descr6
-rw-r--r--multimedia/mjpg-streamer/pkg-plist41
14 files changed, 223 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index b01a1530acff..ab16c2179557 100644
--- a/MOVED
+++ b/MOVED
@@ -14678,7 +14678,6 @@ misc/yaunc||2020-05-05|Has expired: Broken for more than 6 months
multimedia/clipgrab||2020-05-05|Has expired: Broken for more than 6 months
multimedia/libsmacker||2020-05-05|Has expired: Broken for more than 6 months
multimedia/lxdvdrip||2020-05-05|Has expired: Broken for more than 6 months
-multimedia/mjpg-streamer||2020-05-05|Has expired: Broken for more than 6 months
multimedia/vcdpad||2020-05-05|Has expired: Broken for more than 6 months
net/erlang-xmlrpc||2020-05-05|Has expired: Broken for more than 6 months
net/etrace||2020-05-05|Has expired: Broken for more than 6 months
diff --git a/multimedia/mjpg-streamer/Makefile b/multimedia/mjpg-streamer/Makefile
new file mode 100644
index 000000000000..b4a977d3d8aa
--- /dev/null
+++ b/multimedia/mjpg-streamer/Makefile
@@ -0,0 +1,34 @@
+# Created by: Kozlov Sergey <kozlov.sergey.404@gmail.com>
+
+PORTNAME= mjpg-streamer
+PORTVERSION= g2021081601
+PORTEPOCH= 1
+CATEGORIES= multimedia net
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= HTTP video streaming daemon
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev.h:multimedia/v4l_compat
+
+USES= cmake localbase jpeg
+
+USE_GITHUB= yes
+GH_ACCOUNT= jacksonliam
+GH_TAGNAME= 310b29f4a94c46652b20c4b7b6e5cf24e532af39
+
+WRKSRC_SUBDIR= mjpg-streamer-experimental
+
+USE_RC_SUBR= mjpg_streamer
+SUB_FILES+= pkg-message
+
+post-build:
+ cd ${WRKSRC}/plugins/input_testpicture && \
+ ${SETENV} ${MAKE_ENV} make
+
+post-install:
+ ${INSTALL_LIB} ${WRKSRC}/plugins/input_testpicture/input_testpicture.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/multimedia/mjpg-streamer/distinfo b/multimedia/mjpg-streamer/distinfo
new file mode 100644
index 000000000000..32e82f8c64cd
--- /dev/null
+++ b/multimedia/mjpg-streamer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629161369
+SHA256 (jacksonliam-mjpg-streamer-g2021081601-310b29f4a94c46652b20c4b7b6e5cf24e532af39_GH0.tar.gz) = eb4de7fed9f8b15ee6d8ca2b0417aff2854cd018582b7090e28eb0aaa19bc808
+SIZE (jacksonliam-mjpg-streamer-g2021081601-310b29f4a94c46652b20c4b7b6e5cf24e532af39_GH0.tar.gz) = 711738
diff --git a/multimedia/mjpg-streamer/files/mjpg_streamer.in b/multimedia/mjpg-streamer/files/mjpg_streamer.in
new file mode 100644
index 000000000000..41e94fa8608e
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/mjpg_streamer.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: mjpg_streamer
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# mjpg_streamer_enable="YES"
+# #optional
+# mjpg_streamer_flags=""
+
+. /etc/rc.subr
+
+name=mjpg_streamer
+rcvar=mjpg_streamer_enable
+
+command=%%PREFIX%%/bin/${name}
+command_args="-b"
+
+mjpg_streamer_enable="NO"
+mjpg_streamer_flags="-o 'output_http.so -w %%WWWDIR%%'"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/multimedia/mjpg-streamer/files/patch-mjpg__streamer.h b/multimedia/mjpg-streamer/files/patch-mjpg__streamer.h
new file mode 100644
index 000000000000..d6f19fc42e30
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/patch-mjpg__streamer.h
@@ -0,0 +1,10 @@
+--- mjpg_streamer.h.orig 2021-08-17 00:59:00 UTC
++++ mjpg_streamer.h
+@@ -29,6 +29,7 @@
+ #define MAX_OUTPUT_PLUGINS 10
+ #define MAX_PLUGIN_ARGUMENTS 32
+
++#include <netinet/in.h>
+ #include <linux/types.h> /* for videodev2.h */
+ #include <linux/videodev2.h>
+ #include <pthread.h>
diff --git a/multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_Makefile b/multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_Makefile
new file mode 100644
index 000000000000..bd97e8fccd4c
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_Makefile
@@ -0,0 +1,15 @@
+--- plugins/input_testpicture/Makefile.orig 2021-02-20 17:47:40 UTC
++++ plugins/input_testpicture/Makefile
+@@ -7,11 +7,10 @@
+ #
+ ###############################################################
+
+-CC = gcc
+
+ OTHER_HEADERS = ../../mjpg_streamer.h ../../utils.h ../output.h ../input.h
+
+-CFLAGS += -O2 -DLINUX -D_GNU_SOURCE -Wall -shared -fPIC
++CFLAGS += -shared -fPIC
+ #CFLAGS += -DDEBUG
+ LFLAGS += -lpthread -ldl
+
diff --git a/multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_input__testpicture.c b/multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_input__testpicture.c
new file mode 100644
index 000000000000..8b004f725944
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/patch-plugins_input__testpicture_input__testpicture.c
@@ -0,0 +1,11 @@
+--- plugins/input_testpicture/input_testpicture.c.orig 2021-08-17 01:24:22 UTC
++++ plugins/input_testpicture/input_testpicture.c
+@@ -34,7 +34,7 @@
+ #include <pthread.h>
+ #include <syslog.h>
+
+-#include <linux/types.h> /* for videodev2.h */
++#include <sys/types.h> /* for videodev2.h */
+ #include <linux/videodev2.h>
+
+ #include "../../mjpg_streamer.h"
diff --git a/multimedia/mjpg-streamer/files/patch-plugins_output__http_httpd.c b/multimedia/mjpg-streamer/files/patch-plugins_output__http_httpd.c
new file mode 100644
index 000000000000..cb8442b2dfa5
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/patch-plugins_output__http_httpd.c
@@ -0,0 +1,23 @@
+--- plugins/output_http/httpd.c.orig 2021-02-20 17:47:40 UTC
++++ plugins/output_http/httpd.c
+@@ -37,18 +37,17 @@
+ #include <errno.h>
+ #include <limits.h>
+
+-#include <linux/version.h>
+ #include <linux/types.h> /* for videodev2.h */
+ #include <linux/videodev2.h>
+
++#include <netinet/in.h>
++
+ #include "../../mjpg_streamer.h"
+ #include "../../utils.h"
+
+ #include "httpd.h"
+
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
+ #define V4L2_CTRL_TYPE_STRING_SUPPORTED
+-#endif
+
+ #include "../output_file/output_file.h"
+
diff --git a/multimedia/mjpg-streamer/files/patch-plugins_output__rtsp_output__rtsp.c b/multimedia/mjpg-streamer/files/patch-plugins_output__rtsp_output__rtsp.c
new file mode 100644
index 000000000000..d460c7c415c3
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/patch-plugins_output__rtsp_output__rtsp.c
@@ -0,0 +1,10 @@
+--- plugins/output_rtsp/output_rtsp.c.orig 2021-08-17 00:57:41 UTC
++++ plugins/output_rtsp/output_rtsp.c
+@@ -38,6 +38,7 @@
+ #include <errno.h>
+ #include <signal.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <resolv.h>
+ #include <arpa/inet.h>
+ #include <sys/types.h>
diff --git a/multimedia/mjpg-streamer/files/patch-plugins_output__udp_output__udp.c b/multimedia/mjpg-streamer/files/patch-plugins_output__udp_output__udp.c
new file mode 100644
index 000000000000..1809803d61c5
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/patch-plugins_output__udp_output__udp.c
@@ -0,0 +1,10 @@
+--- plugins/output_udp/output_udp.c.orig 2021-08-17 01:14:40 UTC
++++ plugins/output_udp/output_udp.c
+@@ -38,6 +38,7 @@
+ #include <errno.h>
+ #include <signal.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <resolv.h>
+ #include <arpa/inet.h>
+ #include <sys/types.h>
diff --git a/multimedia/mjpg-streamer/files/patch-utils.c b/multimedia/mjpg-streamer/files/patch-utils.c
new file mode 100644
index 000000000000..fdc9e4faa571
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/patch-utils.c
@@ -0,0 +1,18 @@
+--- utils.c.orig 2021-02-20 17:47:40 UTC
++++ utils.c
+@@ -23,13 +23,12 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+-#include <linux/types.h>
++#include <sys/types.h>
+ #include <string.h>
+ #include <fcntl.h>
+-#include <wait.h>
++#include <sys/wait.h>
+ #include <time.h>
+ #include <limits.h>
+-#include <linux/stat.h>
+ #include <sys/stat.h>
+
+ #include "utils.h"
diff --git a/multimedia/mjpg-streamer/files/pkg-message.in b/multimedia/mjpg-streamer/files/pkg-message.in
new file mode 100644
index 000000000000..9f7496eda41a
--- /dev/null
+++ b/multimedia/mjpg-streamer/files/pkg-message.in
@@ -0,0 +1,14 @@
+[
+{ type: install
+ message: <<EOM
+To launch MJPG-streamer demo, run
+%%PREFIX%%/etc/rc.d/mjpg_streamer start
+
+Then point your browser to
+http://your.server.com:8080
+
+To run MJPG-streamer at startup, add
+'mjpg_streamer_enable="YES"' to /etc/rc.conf
+EOM
+}
+]
diff --git a/multimedia/mjpg-streamer/pkg-descr b/multimedia/mjpg-streamer/pkg-descr
new file mode 100644
index 000000000000..24aae218f921
--- /dev/null
+++ b/multimedia/mjpg-streamer/pkg-descr
@@ -0,0 +1,6 @@
+MJPG-streamer takes JPGs from Linux-UVC compatible webcams, filesystem or
+other input plugins and streams them as M-JPEG via HTTP to webbrowsers,
+VLC and other software. It is the successor of uvc-streamer, a Linux-UVC
+streaming application with Pan/Tilt
+
+WWW: https://sourceforge.net/projects/mjpg-streamer/
diff --git a/multimedia/mjpg-streamer/pkg-plist b/multimedia/mjpg-streamer/pkg-plist
new file mode 100644
index 000000000000..f2a9dc48e307
--- /dev/null
+++ b/multimedia/mjpg-streamer/pkg-plist
@@ -0,0 +1,41 @@
+bin/mjpg_streamer
+lib/mjpg-streamer/input_http.so
+lib/mjpg-streamer/input_testpicture.so
+lib/mjpg-streamer/input_uvc.so
+lib/mjpg-streamer/output_file.so
+lib/mjpg-streamer/output_http.so
+lib/mjpg-streamer/output_rtsp.so
+lib/mjpg-streamer/output_udp.so
+%%DATADIR%%/www/JQuerySpinBtn.css
+%%DATADIR%%/www/JQuerySpinBtn.js
+%%DATADIR%%/www/LICENSE.txt
+%%DATADIR%%/www/bodybg.gif
+%%DATADIR%%/www/cambozola.jar
+%%DATADIR%%/www/control.htm
+%%DATADIR%%/www/example.jpg
+%%DATADIR%%/www/favicon.ico
+%%DATADIR%%/www/favicon.png
+%%DATADIR%%/www/fix.css
+%%DATADIR%%/www/functions.js
+%%DATADIR%%/www/index.html
+%%DATADIR%%/www/java.html
+%%DATADIR%%/www/java_control.html
+%%DATADIR%%/www/java_simple.html
+%%DATADIR%%/www/javascript.html
+%%DATADIR%%/www/javascript_motiondetection.html
+%%DATADIR%%/www/javascript_simple.html
+%%DATADIR%%/www/jquery.js
+%%DATADIR%%/www/jquery.rotate.js
+%%DATADIR%%/www/jquery.ui.core.min.js
+%%DATADIR%%/www/jquery.ui.custom.css
+%%DATADIR%%/www/jquery.ui.tabs.min.js
+%%DATADIR%%/www/jquery.ui.widget.min.js
+%%DATADIR%%/www/rotateicons.png
+%%DATADIR%%/www/sidebarbg.gif
+%%DATADIR%%/www/spinbtn_updn.gif
+%%DATADIR%%/www/static.html
+%%DATADIR%%/www/static_simple.html
+%%DATADIR%%/www/stream.html
+%%DATADIR%%/www/stream_simple.html
+%%DATADIR%%/www/style.css
+%%DATADIR%%/www/videolan.html