aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Herschke <lhersch@dssgmbh.de>2023-02-07 19:58:08 +0000
committerSofian Brabez <sbz@FreeBSD.org>2023-02-07 20:12:08 +0000
commit09cce002b069d1053e66b4980b3055de0a8deb4a (patch)
tree39f7ea9c1b2ab3ec47c329bbd384670075991c4a
parent8254b3a476e6714d8e901681e40d2631f7e4b7c5 (diff)
downloadports-09cce002b069d1053e66b4980b3055de0a8deb4a.tar.gz
ports-09cce002b069d1053e66b4980b3055de0a8deb4a.zip
security/dsniff: fix build by using openssl-unsafe
PR: 267387
-rw-r--r--security/dsniff/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 73577db67ca6..a279c5e60d4a 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dsniff
DISTVERSION= 2.4b1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= security
MASTER_SITES= http://www.monkey.org/~dugsong/${PORTNAME}/beta/ \
LOCAL/sbz
@@ -34,17 +34,17 @@ X11_CONFIGURE_WITH=x
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD || ${SSL_DEFAULT} == openssl
-# Requires LibreSSL for old SSL interface
-BUILD_DEPENDS+= ${NONEXISTENT}:security/libressl:stage
-CPPFLAGS+= -nostdinc -I/usr/include -I${WRKDIR}/libressl/include
-LDFLAGS+= -L${WRKDIR}/libressl/lib
-CONFIGURE_ARGS+= --with-openssl=${WRKDIR}/libressl
+# Requires OpenSSL 1.0.x for old SSL interface
+BUILD_DEPENDS+= ${NONEXISTENT}:security/openssl-unsafe:stage
+CPPFLAGS+= -nostdinc -I/usr/include -I${WRKDIR}/openssl-unsafe/include
+LDFLAGS+= -L${WRKDIR}/openssl-unsafe/lib
+CONFIGURE_ARGS+= --with-openssl=${WRKDIR}/openssl-unsafe
# Don't use COPYTREE_SHARE here as it hard links files, and the original files
# are owned by root, which creates problems of its own.
pre-configure:
- @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl`${PREFIX} \
- && ${FIND} . ! -name *.so\* | ${CPIO} -dump ${WRKDIR}/libressl >/dev/null 2>&1
+ @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/openssl-unsafe`${PREFIX}/openssl-unsafe \
+ && ${FIND} . ! -name *.so\* | ${CPIO} -dump ${WRKDIR}/openssl-unsafe >/dev/null 2>&1
.else
BROKEN_SSL= openssl
BROKEN_SSL_REASON_openssl= incomplete definition of type 'struct rsa_st'