aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:03:55 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:03:55 +0000
commit0a0f66e4af5526771ba714077758f66c0cfd001d (patch)
tree91b909917d882d8f8ba6470c9ea7b0dad1ff2250
parentb8a8ec6db49ae40fd19790fc3d2ff21eabe657bc (diff)
downloadports-0a0f66e4af5526771ba714077758f66c0cfd001d.tar.gz
ports-0a0f66e4af5526771ba714077758f66c0cfd001d.zip
graphics/perceptualdiff: fix build without libomp
CMake Error at /usr/local/share/cmake/Modules/FindOpenMP.cmake:261 (try_compile): Failed to generate test project build system. Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindOpenMP.cmake:537 (_OPENMP_GET_FLAGS) CMakeLists.txt:25 (find_package) This warning is for project developers. Use -Wno-dev to suppress it.
-rw-r--r--graphics/perceptualdiff/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/perceptualdiff/Makefile b/graphics/perceptualdiff/Makefile
index df3bfab968a7..59b2c744af1d 100644
--- a/graphics/perceptualdiff/Makefile
+++ b/graphics/perceptualdiff/Makefile
@@ -17,6 +17,11 @@ PLIST_FILES= bin/perceptualdiff
USE_GITHUB= yes
GH_ACCOUNT= myint
-USES= cmake compiler:c++0x
+USES= cmake
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++0x
+.endif
.include <bsd.port.mk>