aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-06-28 17:34:53 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-06-28 17:39:39 +0000
commit0a41062b5b5a90548e1a8b529448dd8a389c6203 (patch)
treed43c97c914712eebc6e8da4d36a6a642bfbe72a4
parentffa7085ab4121e92eb61c4e1f6a7138e7ea43d6a (diff)
downloadports-0a41062b5b5a90548e1a8b529448dd8a389c6203.tar.gz
ports-0a41062b5b5a90548e1a8b529448dd8a389c6203.zip
converters/dos2unix: Add new port
This is a port for Erwin Waterlander's dos2unix, which is shipped in most Linux distributions, and has many more features than the similar converters/dosunix and converters/unix2dos ports. It is also much more maintained, as those other ports have not had significant updates in years. The port has DOCS and NLS options, to toggle the building and/or installing of documentation, multi-lingual messages and man pages. Note that this port's "dos2unix" and "unix2dos" binaries conflict with those of the converters/unix2dos port, but I see no good reason to have both installed at the same time. PR: 271998 Reviewed by: eduardo MFH: 2023Q2
-rw-r--r--converters/Makefile1
-rw-r--r--converters/dos2unix/Makefile31
-rw-r--r--converters/dos2unix/distinfo3
-rw-r--r--converters/dos2unix/pkg-descr18
-rw-r--r--converters/dos2unix/pkg-plist112
5 files changed, 165 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 6f13c8261a34..3782f6bcdac8 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -20,6 +20,7 @@
SUBDIR += cmios9
SUBDIR += cocot
SUBDIR += convmv
+ SUBDIR += dos2unix
SUBDIR += dosunix
SUBDIR += drg2sbg
SUBDIR += dumpasn1
diff --git a/converters/dos2unix/Makefile b/converters/dos2unix/Makefile
new file mode 100644
index 000000000000..239eb3674a6b
--- /dev/null
+++ b/converters/dos2unix/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= dos2unix
+DISTVERSION= 7.5.0
+CATEGORIES= converters
+MASTER_SITES= SF \
+ https://waterlan.home.xs4all.nl/dos2unix/
+
+MAINTAINER= dim@FreeBSD.org
+COMMENT= DOS/Mac to Unix and vice versa text file format converter
+WWW= https://waterlan.home.xs4all.nl/dos2unix.html
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+USES= gmake
+
+MAKE_ARGS= docsubdir="${PORTNAME}" \
+ prefix="${PREFIX}"
+
+CONFLICTS_INSTALL= unix2dos
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_MAKE_ARGS_OFF= ENABLE_NLS=
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dos2unix
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/unix2dos
+
+.include <bsd.port.mk>
diff --git a/converters/dos2unix/distinfo b/converters/dos2unix/distinfo
new file mode 100644
index 000000000000..5bebdae68149
--- /dev/null
+++ b/converters/dos2unix/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1686736752
+SHA256 (dos2unix-7.5.0.tar.gz) = 7a3b01d01e214d62c2b3e04c3a92e0ddc728a385566e4c0356efa66fd6eb95af
+SIZE (dos2unix-7.5.0.tar.gz) = 957576
diff --git a/converters/dos2unix/pkg-descr b/converters/dos2unix/pkg-descr
new file mode 100644
index 000000000000..d1a39dd58a58
--- /dev/null
+++ b/converters/dos2unix/pkg-descr
@@ -0,0 +1,18 @@
+This is an update of Benjamin Lin's implementations of dos2unix and
+unix2dos. Benjamin Lin's implementations of dos2unix and unix2dos were
+distributed via SunSITE.unc.edu (later MetaLab.unc.edu, now ibiblio)
+and became part of several Linux distributions such as RedHat, Suse,
+Gentoo, and others. This update includes all RedHat patches and fixes
+several other problems. Internationalization has been added and ports
+to DOS, Windows, Cygwin and OS/2 Warp have been made.
+
+Features
+* Native language support.
+* Automatically skips binary and non-regular files.
+* In-place, paired, or stdio mode conversion.
+* Keep original file dates option.
+* 7-bit and iso conversion modes like SunOS dos2unix.
+* Conversion of Unicode UTF-16 files.
+* Handles Unicode Byte Order Mark (BOM).
+* Display file information.
+* Secure.
diff --git a/converters/dos2unix/pkg-plist b/converters/dos2unix/pkg-plist
new file mode 100644
index 000000000000..2de8626fd161
--- /dev/null
+++ b/converters/dos2unix/pkg-plist
@@ -0,0 +1,112 @@
+bin/dos2unix
+bin/mac2unix
+bin/unix2dos
+bin/unix2mac
+%%DOCS%%%%DOCSDIR%%/BUGS.txt
+%%DOCS%%%%DOCSDIR%%/ChangeLog.txt
+%%DOCS%%%%DOCSDIR%%/COPYING.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/de/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/de/dos2unix.txt
+%%DOCS%%%%DOCSDIR%%/dos2unix.htm
+%%DOCS%%%%DOCSDIR%%/dos2unix.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/es/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/es/dos2unix.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/fr/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/fr/dos2unix.txt
+%%DOCS%%%%DOCSDIR%%/INSTALL.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/ko/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/ko/dos2unix.txt
+%%DOCS%%%%DOCSDIR%%/NEWS.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/nl/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/nl/dos2unix.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/pl/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/pl/dos2unix.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/pt_BR/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/pt_BR/dos2unix.txt
+%%DOCS%%%%DOCSDIR%%/README.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/ro/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/ro/dos2unix.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/sr/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/sr/dos2unix.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/sv/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/sv/dos2unix.txt
+%%DOCS%%%%DOCSDIR%%/TODO.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/uk/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/uk/dos2unix.txt
+%%DOCS%%%%NLS%%%%DOCSDIR%%/zh_CN/dos2unix.htm
+%%DOCS%%%%NLS%%%%DOCSDIR%%/zh_CN/dos2unix.txt
+%%NLS%%share/locale/ca/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/da/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/de/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/es/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/fur/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/dos2unix.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/dos2unix.mo
+%%DOCS%%%%NLS%%share/man/de/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/de/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/de/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/de/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/es/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/es/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/es/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/es/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/fr/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/fr/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/fr/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/fr/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/ko/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/ko/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/ko/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/ko/man1/unix2mac.1.gz
+%%DOCS%%share/man/man1/dos2unix.1.gz
+%%DOCS%%share/man/man1/mac2unix.1.gz
+%%DOCS%%share/man/man1/unix2dos.1.gz
+%%DOCS%%share/man/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/nl/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/nl/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/nl/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/nl/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/pl/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/pl/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/pl/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/pl/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/pt_BR/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/pt_BR/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/pt_BR/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/pt_BR/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/ro/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/ro/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/ro/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/ro/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/sr/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/sr/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/sr/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/sr/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/sv/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/sv/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/sv/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/sv/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/uk/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/uk/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/uk/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/uk/man1/unix2mac.1.gz
+%%DOCS%%%%NLS%%share/man/zh_CN/man1/dos2unix.1.gz
+%%DOCS%%%%NLS%%share/man/zh_CN/man1/mac2unix.1.gz
+%%DOCS%%%%NLS%%share/man/zh_CN/man1/unix2dos.1.gz
+%%DOCS%%%%NLS%%share/man/zh_CN/man1/unix2mac.1.gz