aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-29 16:14:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-29 16:14:29 +0000
commit0b1913591f0e199f6c9e89d9d50624f5023571a7 (patch)
treeac748f5f8f6ed6086c95c3c9e5c45ef6988c2265
parentaef96349c791de66b4a685c713ef1042aac1d4b2 (diff)
downloadports-0b1913591f0e199f6c9e89d9d50624f5023571a7.tar.gz
ports-0b1913591f0e199f6c9e89d9d50624f5023571a7.zip
www/py-aiostream: Update to 0.5.0
- Update WWW - Allow concurrent installation (USE_PYTHON=concurrent) - Add NO_ARCH - Update pkg-descr - Take maintainership Changes: https://github.com/vxgmichel/aiostream/releasesA
-rw-r--r--www/py-aiostream/Makefile13
-rw-r--r--www/py-aiostream/distinfo6
-rw-r--r--www/py-aiostream/pkg-descr24
3 files changed, 24 insertions, 19 deletions
diff --git a/www/py-aiostream/Makefile b/www/py-aiostream/Makefile
index 33f80ec909d9..cd0b176b17fe 100644
--- a/www/py-aiostream/Makefile
+++ b/www/py-aiostream/Makefile
@@ -1,17 +1,22 @@
PORTNAME= aiostream
-DISTVERSION= 0.4.5
+PORTVERSION= 0.5.0
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Generator-based operators for asynchronous iteration
-WWW= https://github.com/vxgmichel/aiostream
+WWW= https://aiostream.readthedocs.io/en/stable/ \
+ https://github.com/vxgmichel/aiostream
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
+
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/www/py-aiostream/distinfo b/www/py-aiostream/distinfo
index 5718735ce069..2bcb6f80dadb 100644
--- a/www/py-aiostream/distinfo
+++ b/www/py-aiostream/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1671508635
-SHA256 (aiostream-0.4.5.tar.gz) = 3ecbf87085230fbcd9605c32ca20c4fb41af02c71d076eab246ea22e35947d88
-SIZE (aiostream-0.4.5.tar.gz) = 32627
+TIMESTAMP = 1695588846
+SHA256 (aiostream-0.5.0.tar.gz) = d64aa63cb9b96b4dae74b09f260d2d0fa423fbbd17bce29ed39ff8e5caf95b57
+SIZE (aiostream-0.5.0.tar.gz) = 35156
diff --git a/www/py-aiostream/pkg-descr b/www/py-aiostream/pkg-descr
index d84029f20ae4..abac86098266 100644
--- a/www/py-aiostream/pkg-descr
+++ b/www/py-aiostream/pkg-descr
@@ -1,13 +1,13 @@
-Generator-based operators for asynchronous iteration.
+aiostream provides a collection of stream operators that can be combined to
+create asynchronous pipelines of operations.
-It can be seen as an asynchronous version of itertools, although some
-aspects are slightly different. Essentially, all the provided operators
-return a unified interface called a stream. A stream is an enhanced
-asynchronous iterable providing the following features:
-
- - Operator pipe-lining - using pipe symbol '|'
- - Repeatability - every iteration creates a different iterator
- - Safe iteration context - using 'async with' and the 'stream' method
- - Simplified execution - get the last element from a stream using 'await'
- - Slicing and indexing - using square brackets '[]'
- - Concatenation - using addition symbol '+'
+It can be seen as an asynchronous version of itertools, although some aspects
+are slightly different. Essentially, all the provided operators return a unified
+interface called a stream. A stream is an enhanced asynchronous iterable
+providing the following features:
+- Operator pipe-lining - using pipe symbol |
+- Repeatability - every iteration creates a different iterator
+- Safe iteration context - using async with and the stream method
+- Simplified execution - get the last element from a stream using await
+- Slicing and indexing - using square brackets []
+- Concatenation - using addition symbol +