aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:46:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:10:50 +0000
commit0b20522687fbbb5676e34a30d8c77e305355632a (patch)
tree44430fa9b0da639a412376b944b413e5f295467b
parent602fe741724a7a973b6dac6e49494db18920c046 (diff)
downloadports-0b20522687fbbb5676e34a30d8c77e305355632a.tar.gz
ports-0b20522687fbbb5676e34a30d8c77e305355632a.zip
devel/py-findpython: Add py-findpython 0.1.3
This library is a rewrite of pythonfinder project by @techalchemy. It simplifies the whole code structure while preserving most of the original features. WWW: https://github.com/frostming/findpython
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-findpython/Makefile25
-rw-r--r--devel/py-findpython/distinfo3
-rw-r--r--devel/py-findpython/files/setup.py49
-rw-r--r--devel/py-findpython/pkg-descr4
5 files changed, 82 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4b54012d2645..8dbfb04cd2fe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4516,6 +4516,7 @@
SUBDIR += py-filemagic
SUBDIR += py-filetype
SUBDIR += py-findlibs
+ SUBDIR += py-findpython
SUBDIR += py-first
SUBDIR += py-five.globalrequest
SUBDIR += py-fixtures
diff --git a/devel/py-findpython/Makefile b/devel/py-findpython/Makefile
new file mode 100644
index 000000000000..6e5a3c779208
--- /dev/null
+++ b/devel/py-findpython/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= findpython
+PORTVERSION= 0.1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Utility to find python versions on your system
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=20:devel/py-packaging@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/devel/py-findpython/distinfo b/devel/py-findpython/distinfo
new file mode 100644
index 000000000000..e99a7451f9c4
--- /dev/null
+++ b/devel/py-findpython/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646057846
+SHA256 (findpython-0.1.3.tar.gz) = b55a416b9fcf2d28721bfbea1ceb2a6cb67a00f99ec4b94a76da22c7a2002870
+SIZE (findpython-0.1.3.tar.gz) = 15554
diff --git a/devel/py-findpython/files/setup.py b/devel/py-findpython/files/setup.py
new file mode 100644
index 000000000000..96d31653b1cf
--- /dev/null
+++ b/devel/py-findpython/files/setup.py
@@ -0,0 +1,49 @@
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+import codecs
+
+with codecs.open('README.md', encoding="utf-8") as fp:
+ long_description = fp.read()
+INSTALL_REQUIRES = [
+ 'packaging>=20',
+]
+ENTRY_POINTS = {
+ 'console_scripts': [
+ 'findpython = findpython.__main__:main',
+ ],
+}
+
+setup_kwargs = {
+ 'name': 'findpython',
+ 'version': '%%PORTVERSION%%',
+ 'description': 'A utility to find python versions on your system',
+ 'long_description': long_description,
+ 'license': 'MIT',
+ 'author': '',
+ 'author_email': 'Frost Ming <mianghong@gmail.com>',
+ 'maintainer': None,
+ 'maintainer_email': None,
+ 'url': '',
+ 'packages': [
+ 'findpython',
+ 'findpython._vendor',
+ 'findpython._vendor.pep514tools',
+ 'findpython.providers',
+ ],
+ 'package_dir': {'': 'src'},
+ 'package_data': {'': ['*']},
+ 'long_description_content_type': 'text/markdown',
+ 'classifiers': [
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ ],
+ 'install_requires': INSTALL_REQUIRES,
+ 'python_requires': '>=3.7',
+ 'entry_points': ENTRY_POINTS,
+}
+
+setup(**setup_kwargs)
diff --git a/devel/py-findpython/pkg-descr b/devel/py-findpython/pkg-descr
new file mode 100644
index 000000000000..fef1df9629f3
--- /dev/null
+++ b/devel/py-findpython/pkg-descr
@@ -0,0 +1,4 @@
+This library is a rewrite of pythonfinder project by @techalchemy. It simplifies
+the whole code structure while preserving most of the original features.
+
+WWW: https://github.com/frostming/findpython