aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank Scholl <maintainer.freebsd@xpoundit.com>2021-08-06 13:31:10 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-08-06 13:31:10 +0000
commit0b34ae623a58b1975b3e2f009f95239e3e950695 (patch)
tree487f670ab233b5e297c0573b6a17d772b3870015
parent4c9e650ddc326b6b1837720894a338a48b3d29ed (diff)
downloadports-0b34ae623a58b1975b3e2f009f95239e3e950695.tar.gz
ports-0b34ae623a58b1975b3e2f009f95239e3e950695.zip
science/orthanc-webviewer: Revive port
Plugin to extend Orthanc with a Web viewer of medical images. PR: 242549
-rw-r--r--MOVED1
-rw-r--r--science/Makefile1
-rw-r--r--science/orthanc-webviewer/Makefile64
-rw-r--r--science/orthanc-webviewer/distinfo17
-rw-r--r--science/orthanc-webviewer/pkg-descr11
-rw-r--r--science/orthanc-webviewer/pkg-plist2
6 files changed, 95 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index cb16125308a4..8c8b74fe0dba 100644
--- a/MOVED
+++ b/MOVED
@@ -10154,7 +10154,6 @@ audio/abcmidi||2018-06-07|Has expired: Broken for more than 6 months
benchmarks/netpipe||2018-06-07|Has expired: Broken for more than 6 months
science/orthanc-dicomweb||2018-06-07|Removed, depends on expired science/orthanc
science/orthanc-postgresql||2018-06-07|Removed, depends on expired science/orthanc
-science/orthanc-webviewer||2018-06-07|Removed, depends on expired science/orthanc
graphics/libkface||2018-06-09|Has expired: No longer maintained upstream
math/scilab-toolbox-sivp||2018-06-09|Has expired: Cannot build with newer opencv
math/clipper|graphics/polyclipping|2018-06-11|Duplicate port
diff --git a/science/Makefile b/science/Makefile
index 9c49c7e03605..e043cab1c2b9 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -177,6 +177,7 @@
SUBDIR += opensph
SUBDIR += opsin
SUBDIR += orthanc
+ SUBDIR += orthanc-webviewer
SUBDIR += p5-Algorithm-SVMLight
SUBDIR += p5-Chemistry-3DBuilder
SUBDIR += p5-Chemistry-Bond-Find
diff --git a/science/orthanc-webviewer/Makefile b/science/orthanc-webviewer/Makefile
new file mode 100644
index 000000000000..1f3b768954d4
--- /dev/null
+++ b/science/orthanc-webviewer/Makefile
@@ -0,0 +1,64 @@
+# Created by: maintainer.freebsd@xpoundit.com
+
+PORTNAME= orthanc-webviewer
+DISTVERSION= 2.7
+CATEGORIES= science
+MASTER_SITES= https://www.orthanc-server.com/downloads/get.php?path=/plugin-webviewer/:main \
+ https://www.orthanc-server.com/downloads/get.php?path=/orthanc/:framework \
+ http://orthanc.osimis.io/ThirdPartyDownloads/WebViewer/:thirdpartywebviewer \
+ http://orthanc.osimis.io/ThirdPartyDownloads/:thirdparty
+DISTFILES= OrthancWebViewer-${PORTVERSION}.tar.gz:main \
+ jsPanel-2.3.3-fixed.zip:thirdpartywebviewer \
+ cornerstone-0.11.0.zip:thirdpartywebviewer \
+ jquery-ui-1.11.3.zip:thirdpartywebviewer \
+ pako-0.2.5.zip:thirdpartywebviewer \
+ js-url-1.8.6.zip:thirdpartywebviewer \
+ Orthanc-1.8.1.tar.gz:framework \
+ e2fsprogs-1.44.5.tar.gz:thirdparty
+DIST_SUBDIR= orthanc
+EXTRACT_ONLY= OrthancWebViewer-${PORTVERSION}.tar.gz
+
+MAINTAINER= maintainer.freebsd@xpoundit.com
+COMMENT= Plugin to extend Orthanc with a Web viewer of medical images
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/orthanc/OrthancCPlugin.h:science/orthanc
+LIB_DEPENDS= libboost_atomic.so:devel/boost-libs \
+ libexpat.so:textproc/expat2 \
+ libgdcmCommon.so:devel/gdcm \
+ libicudata.so:devel/icu \
+ libjsoncpp.so:devel/jsoncpp \
+ libopenjp2.so:graphics/openjpeg \
+ libsqlite3.so:databases/sqlite3
+RUN_DEPENDS= Orthanc:science/orthanc
+
+USES= cmake localbase python:build
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/OrthancWebViewer-${PORTVERSION}
+
+CMAKE_OFF= USE_SYSTEM_UUID
+CMAKE_ARGS= -DORTHANC_FRAMEWORK_ROOT=${WRKSRC}/ThirdPartyDownloads/Orthanc-1.8.1/OrthancFramework/Sources \
+ -DORTHANC_FRAMEWORK_SOURCE=path
+CFLAGS+= -I${LOCALBASE}/include -DORTHANC_ENABLE_LOGGING_PLUGIN -DNDEBUG
+CXXFLAGS+= -DNDEBUG
+
+PLIST_SUB= DISTVERSION=${DISTVERSION}
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/ThirdPartyDownloads
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/jsPanel-2.3.3-fixed.zip ${WRKSRC}/ThirdPartyDownloads
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/cornerstone-0.11.0.zip ${WRKSRC}/ThirdPartyDownloads
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/jquery-ui-1.11.3.zip ${WRKSRC}/ThirdPartyDownloads
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/pako-0.2.5.zip ${WRKSRC}/ThirdPartyDownloads
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/js-url-1.8.6.zip ${WRKSRC}/ThirdPartyDownloads
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/e2fsprogs-1.44.5.tar.gz ${WRKSRC}/ThirdPartyDownloads
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/Orthanc-1.8.1.tar.gz ${WRKSRC}/ThirdPartyDownloads
+ ${TAR} -C ${WRKSRC}/ThirdPartyDownloads -xf ${WRKSRC}/ThirdPartyDownloads/Orthanc-1.8.1.tar.gz
+
+post-build:
+ @cd ${BUILD_WRKSRC} && ./UnitTests
+
+.include <bsd.port.mk>
diff --git a/science/orthanc-webviewer/distinfo b/science/orthanc-webviewer/distinfo
new file mode 100644
index 000000000000..e6d964173af3
--- /dev/null
+++ b/science/orthanc-webviewer/distinfo
@@ -0,0 +1,17 @@
+TIMESTAMP = 1620907941
+SHA256 (orthanc/OrthancWebViewer-2.7.tar.gz) = 22f56136e4704c734f80d3a9a0fed892c6516be45c30f524b10f93413a3eb81f
+SIZE (orthanc/OrthancWebViewer-2.7.tar.gz) = 124764
+SHA256 (orthanc/jsPanel-2.3.3-fixed.zip) = 958a15c7009efbb865da62b5850a3a39661c62696e38b151c7f988f4ac445595
+SIZE (orthanc/jsPanel-2.3.3-fixed.zip) = 826542
+SHA256 (orthanc/cornerstone-0.11.0.zip) = 1bada9f1f2981968f72daa352e712abea5cac3e0417fe59176f70a23261f1da9
+SIZE (orthanc/cornerstone-0.11.0.zip) = 935277
+SHA256 (orthanc/jquery-ui-1.11.3.zip) = 045b52f293bf4f77c6689569064327495edd9e6434839b78a56299c555130282
+SIZE (orthanc/jquery-ui-1.11.3.zip) = 400437
+SHA256 (orthanc/pako-0.2.5.zip) = e493010e1b1af5c149631994365ed31e15722eed2d17cc1d95bd9af151f2005f
+SIZE (orthanc/pako-0.2.5.zip) = 704378
+SHA256 (orthanc/js-url-1.8.6.zip) = ef2c7f50921ba64ac434eacf025669f1e6f39b5584100ffa8194a3edc08d43d3
+SIZE (orthanc/js-url-1.8.6.zip) = 54717
+SHA256 (orthanc/Orthanc-1.8.1.tar.gz) = 475f0e09d53496f5c152f3a4af9eb7318826f8d475f061d8e5332e4e6473c080
+SIZE (orthanc/Orthanc-1.8.1.tar.gz) = 1701085
+SHA256 (orthanc/e2fsprogs-1.44.5.tar.gz) = 2e211fae27ef74d5af4a4e40b10b8df7f87c655933bd171aab4889bfc4e6d1cc
+SIZE (orthanc/e2fsprogs-1.44.5.tar.gz) = 7619237
diff --git a/science/orthanc-webviewer/pkg-descr b/science/orthanc-webviewer/pkg-descr
new file mode 100644
index 000000000000..2a9f2b17ed4e
--- /dev/null
+++ b/science/orthanc-webviewer/pkg-descr
@@ -0,0 +1,11 @@
+Orthanc can be extended by a plugin that brings a Web viewer of medical
+images. The Web viewer is based upon the two following projects:
+
+Cornerstone (https://github.com/chafey/cornerstone), a client-side JavaScript
+library to display medical images in Web browsers, by Chris Hafey, and
+
+GDCM (http://sourceforge.net/projects/gdcm/), an open-source implementation
+of the DICOM standard with advanced features for image decoding, by Mathieu
+Malaterre.
+
+WWW: https://www.orthanc-server.com/static.php?page=web-viewer
diff --git a/science/orthanc-webviewer/pkg-plist b/science/orthanc-webviewer/pkg-plist
new file mode 100644
index 000000000000..42a8c31e97c1
--- /dev/null
+++ b/science/orthanc-webviewer/pkg-plist
@@ -0,0 +1,2 @@
+share/orthanc/plugins/libOrthancWebViewer.so
+share/orthanc/plugins/libOrthancWebViewer.so.%%DISTVERSION%%