aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-10 14:25:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-10 14:45:56 +0000
commit0b508f745511d43d26d45f10b12bd4884a71452f (patch)
treea199b6956fecf0e4c1dd4a8d2f015e0a567096ec
parentda7740aa6dbf2505a8c72ad7b01e1b21851277e4 (diff)
downloadports-0b508f745511d43d26d45f10b12bd4884a71452f.tar.gz
ports-0b508f745511d43d26d45f10b12bd4884a71452f.zip
security/py-pysaml26: Add py-pysaml26 6.5.1 (copied from py-pysaml2)
- Add PORTSCOUT
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pysaml26/Makefile43
-rw-r--r--security/py-pysaml26/distinfo3
-rw-r--r--security/py-pysaml26/pkg-descr6
4 files changed, 53 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index beb0d2fd2a0a..e355ef901cf7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -954,6 +954,7 @@
SUBDIR += py-pyotp2289
SUBDIR += py-pysaml2
SUBDIR += py-pysaml24
+ SUBDIR += py-pysaml26
SUBDIR += py-pyscard
SUBDIR += py-pysha3
SUBDIR += py-pysodium
diff --git a/security/py-pysaml26/Makefile b/security/py-pysaml26/Makefile
new file mode 100644
index 000000000000..2c919222a41f
--- /dev/null
+++ b/security/py-pysaml26/Makefile
@@ -0,0 +1,43 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+
+PORTNAME= pysaml2
+PORTVERSION= 6.5.1
+CATEGORIES= security devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 6
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python implementation of SAML Version 2
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.4:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}defusedxml>=0:devel/py-defusedxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}importlib-resources>=0:devel/py-importlib-resources@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Paste>=0:www/py-paste@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0,1:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}repoze.who>=0:devel/py-repoze.who@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xmlschema>=0:textproc/py-xmlschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR} \
+ xmlsec1:security/xmlsec1
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}responses>=0:devel/py-responses@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
+
+.include <bsd.port.mk>
diff --git a/security/py-pysaml26/distinfo b/security/py-pysaml26/distinfo
new file mode 100644
index 000000000000..3d76dfd0c07c
--- /dev/null
+++ b/security/py-pysaml26/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1611856594
+SHA256 (pysaml2-6.5.1.tar.gz) = 6dc798aae0e2d43425cd3c720da1aea1b99e52c7e7d87d3666c8854f35e862f6
+SIZE (pysaml2-6.5.1.tar.gz) = 357718
diff --git a/security/py-pysaml26/pkg-descr b/security/py-pysaml26/pkg-descr
new file mode 100644
index 000000000000..4cec27f7961f
--- /dev/null
+++ b/security/py-pysaml26/pkg-descr
@@ -0,0 +1,6 @@
+PySAML2 is a pure python implementation of SAML2. It contains all necessary
+pieces for building a SAML2 service provider or an identity provider. The
+distribution contains examples of both. Originally written to work in a WSGI
+environment there are extensions that allow you to use it with other frameworks.
+
+WWW: https://github.com/IdentityPython/pysaml2