aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 20:19:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 20:19:16 +0000
commit0b8bff01ae1100230278ad836ee0b081b1e62d51 (patch)
tree6c320eb64eedca74324055fb03628d9140cb5f6f
parent9d43812b94aebe91429204e9f39d6200e0ce281b (diff)
downloadports-0b8bff01ae1100230278ad836ee0b081b1e62d51.tar.gz
ports-0b8bff01ae1100230278ad836ee0b081b1e62d51.zip
devel/rubygem-gettext_i18n_rails_js: Add rubygem-gettext_i18n_rails_js 2.1.0
GettextI18nRailsJs extends gettext_i18n_rails, making your .PO files available to client side Javascript as JSON. It will find translations inside your .js, .coffee, .handlebars and .mustache files, then it will create JSON versions of your .PO files so you can serve them with the rest of your assets, thus letting you access all your translations offline from client side Javascript.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-gettext_i18n_rails_js/Makefile22
-rw-r--r--devel/rubygem-gettext_i18n_rails_js/distinfo3
-rw-r--r--devel/rubygem-gettext_i18n_rails_js/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2ec9718ecfa7..bc98e32ee8c7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7055,6 +7055,7 @@
SUBDIR += rubygem-gettext-setup
SUBDIR += rubygem-gettext_i18n_rails
SUBDIR += rubygem-gettext_i18n_rails111
+ SUBDIR += rubygem-gettext_i18n_rails_js
SUBDIR += rubygem-gettext_i18n_rails_js-rails5
SUBDIR += rubygem-gettext_i18n_rails_js-rails50
SUBDIR += rubygem-gettext_i18n_rails_js-rails52
diff --git a/devel/rubygem-gettext_i18n_rails_js/Makefile b/devel/rubygem-gettext_i18n_rails_js/Makefile
new file mode 100644
index 000000000000..1fd81f26ac8b
--- /dev/null
+++ b/devel/rubygem-gettext_i18n_rails_js/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= gettext_i18n_rails_js
+PORTVERSION= 2.1.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Make gettext_i18n_rails .po files as JSON
+WWW= https://github.com/webhippie/gettext_i18n_rails_js
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-gettext>=3.0.2:devel/rubygem-gettext \
+ rubygem-gettext_i18n_rails>=0.7.1:devel/rubygem-gettext_i18n_rails \
+ rubygem-po_to_json>=2.0.0:converters/rubygem-po_to_json \
+ rubygem-rails71>=3.2.0:www/rubygem-rails71
+
+USES= gem
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-gettext_i18n_rails_js/distinfo b/devel/rubygem-gettext_i18n_rails_js/distinfo
new file mode 100644
index 000000000000..59aa1b072159
--- /dev/null
+++ b/devel/rubygem-gettext_i18n_rails_js/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1716892222
+SHA256 (rubygem/gettext_i18n_rails_js-2.1.0.gem) = 2c9e537537d02c549198b9e4567c3b8d31f7c0cd77810a9eadd0b2d17d1d9d36
+SIZE (rubygem/gettext_i18n_rails_js-2.1.0.gem) = 26112
diff --git a/devel/rubygem-gettext_i18n_rails_js/pkg-descr b/devel/rubygem-gettext_i18n_rails_js/pkg-descr
new file mode 100644
index 000000000000..c2e3e332aaf3
--- /dev/null
+++ b/devel/rubygem-gettext_i18n_rails_js/pkg-descr
@@ -0,0 +1,5 @@
+GettextI18nRailsJs extends gettext_i18n_rails, making your .PO files available
+to client side Javascript as JSON. It will find translations inside your .js,
+.coffee, .handlebars and .mustache files, then it will create JSON versions of
+your .PO files so you can serve them with the rest of your assets, thus letting
+you access all your translations offline from client side Javascript.