aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2023-02-13 15:14:12 +0000
committerAlex Dupre <ale@FreeBSD.org>2023-02-13 15:15:04 +0000
commit0b947cb693c987b354bbfc38b12bb0f5d2f3027b (patch)
treeba76a9176d429fc608f5a7e736bb66c638352172
parent3fb0bd0a346bd9e2445f6f1f8d0dbc171213104f (diff)
downloadports-0b947cb693c987b354bbfc38b12bb0f5d2f3027b.tar.gz
ports-0b947cb693c987b354bbfc38b12bb0f5d2f3027b.zip
lang/solidity: move OSVERSION check after <bsd.port.options.mk>.
-rw-r--r--lang/solidity/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index 17fe363ea043..b94da21cce7c 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -32,10 +32,6 @@ Z3_CMAKE_OFF= USE_Z3
CVC4_CMAKE_OFF= USE_CVC4
CVC4_BROKEN= solidity uses cvc4 which has been succeeded by cvc5
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
-CXXFLAGS= -Wno-unqualified-std-cast-call
-.endif
-
CMAKE_ARGS+= -DUSE_LD_GOLD=OFF -DTESTS=OFF \
-DRANGE_V3_INCLUDE_DIR="${LOCALBASE}/include" \
-DJSONCPP_INCLUDE_DIR:STRING="${LOCALBASE}/include/jsoncpp" \
@@ -45,6 +41,12 @@ CMAKE_ARGS+= -DUSE_LD_GOLD=OFF -DTESTS=OFF \
PLIST_FILES= bin/solc \
bin/yul-phaser
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+CXXFLAGS+= -Wno-unqualified-std-cast-call
+.endif
+
pre-patch:
@${CP} ${FILESDIR}/fmtlib.cmake ${FILESDIR}/jsoncpp.cmake ${WRKSRC}/cmake/
@${REINPLACE_CMD} '/EthCcache/d' ${WRKSRC}/CMakeLists.txt