aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 15:48:15 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 16:09:36 +0000
commit0bcb644557070bdba262db02124be57572ec30c7 (patch)
treee1e61d3129bf6c30c6936f5f5c29ded3db3ca12e
parentaf826bb9a862aeffb896e8a621b31d4a382e2496 (diff)
downloadports-0bcb644557070bdba262db02124be57572ec30c7.tar.gz
ports-0bcb644557070bdba262db02124be57572ec30c7.zip
textproc/py-pyexcel: Add py-pyexcel 0.6.6
pyexcel lets you focus on data, instead of file formats. It supports csv, tsv, csvz, tsvz, xls, xlsx, xlsm, ods, fods, json, html, simple, rst and media wiki table. WWW: https://github.com/pyexcel/pyexcel
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-pyexcel/Makefile34
-rw-r--r--textproc/py-pyexcel/distinfo3
-rw-r--r--textproc/py-pyexcel/pkg-descr5
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 833f0a829841..bc8ebf2eec7f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1369,6 +1369,7 @@
SUBDIR += py-pyahocorasick
SUBDIR += py-pyaml
SUBDIR += py-pycountry
+ SUBDIR += py-pyexcel
SUBDIR += py-pygccxml
SUBDIR += py-pygments
SUBDIR += py-pygments-25
diff --git a/textproc/py-pyexcel/Makefile b/textproc/py-pyexcel/Makefile
new file mode 100644
index 000000000000..246d50d33f98
--- /dev/null
+++ b/textproc/py-pyexcel/Makefile
@@ -0,0 +1,34 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyexcel
+PORTVERSION= 0.6.6
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Provide one API to read, manipulate and writedata in different excel formats
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lml>=0.0.4:devel/py-lml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyexcel-io>=0.6.2:textproc/py-pyexcel-io@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}texttable>=0.8.2:textproc/py-texttable@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= ODS XLS XLSX
+OPTIONS_DEFAULT=ODS XLS XLSX
+ODS_DESC= OpenDocument spreadsheet (.ods) support
+XLS_DESC= Microsoft Excel 97-2003 (.xls) support
+XLSX_DESC= Microsoft Excel 2007- (.xlsx) support
+
+ODS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyexcel-ods3>=0.6.0:textproc/py-pyexcel-ods3@${PY_FLAVOR}
+XLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyexcel-xls>=0.6.0:textproc/py-pyexcel-xls@${PY_FLAVOR}
+XLSX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyexcel-xlsx>=0.6.0:textproc/py-pyexcel-xlsx@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pyexcel/distinfo b/textproc/py-pyexcel/distinfo
new file mode 100644
index 000000000000..ab839c881ca1
--- /dev/null
+++ b/textproc/py-pyexcel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625585428
+SHA256 (pyexcel-0.6.6.tar.gz) = 39b0bb8f033d9b5523b126cf5a5259d1990ea82b8a23c8eab7aa5e23116803df
+SIZE (pyexcel-0.6.6.tar.gz) = 806792
diff --git a/textproc/py-pyexcel/pkg-descr b/textproc/py-pyexcel/pkg-descr
new file mode 100644
index 000000000000..cdf71db41055
--- /dev/null
+++ b/textproc/py-pyexcel/pkg-descr
@@ -0,0 +1,5 @@
+pyexcel lets you focus on data, instead of file formats. It supports csv, tsv,
+csvz, tsvz, xls, xlsx, xlsm, ods, fods, json, html, simple, rst and media wiki
+table.
+
+WWW: https://github.com/pyexcel/pyexcel