aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPat Maddox <pat@patmaddox.com>2023-10-21 13:47:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2023-10-21 13:47:10 +0000
commit0c5931785acf6f3880f37a9a8e6dc6fc401093e4 (patch)
treef7b17b4491dc2a4cfb684508945a689bd0c3552e
parent1465ea577c4ed49f2a7220ad63e1f950fd424c66 (diff)
downloadports-0c5931785acf6f3880f37a9a8e6dc6fc401093e4.tar.gz
ports-0c5931785acf6f3880f37a9a8e6dc6fc401093e4.zip
devel/py-mashumaro: new port
When using dataclasses, you often need to dump and load objects based on the schema you have. Mashumaro not only lets you save and load things in different ways, but it also does it super quick. Key features: - One of the fastest libraries - Mature and time-tested - Easy to use out of the box - Highly customizable - Built-in support for JSON, YAML, MessagePack, TOML - Built-in support for almost all Python types including typing-extensions - JSON Schema generation PR: 274575 Author: Pat Maddox <pat@patmaddox.com>
-rw-r--r--devel/py-mashumaro/Makefile18
-rw-r--r--devel/py-mashumaro/distinfo3
-rw-r--r--devel/py-mashumaro/pkg-descr13
3 files changed, 34 insertions, 0 deletions
diff --git a/devel/py-mashumaro/Makefile b/devel/py-mashumaro/Makefile
new file mode 100644
index 000000000000..cab97f35a499
--- /dev/null
+++ b/devel/py-mashumaro/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= mashumaro
+PORTVERSION= 3.9
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= pat@patmaddox.com
+COMMENT= Fast serialization library on top of dataclasses
+WWW= https://github.com/Fatal1ty/mashumaro
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.1.0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-mashumaro/distinfo b/devel/py-mashumaro/distinfo
new file mode 100644
index 000000000000..b48aaa96878c
--- /dev/null
+++ b/devel/py-mashumaro/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1691525565
+SHA256 (mashumaro-3.9.tar.gz) = c179f3f29f7b88acc9472427ce9fc673072a04b3888ce4bd1cac94c266c8e587
+SIZE (mashumaro-3.9.tar.gz) = 106417
diff --git a/devel/py-mashumaro/pkg-descr b/devel/py-mashumaro/pkg-descr
new file mode 100644
index 000000000000..87cc263dff43
--- /dev/null
+++ b/devel/py-mashumaro/pkg-descr
@@ -0,0 +1,13 @@
+When using dataclasses, you often need to dump and load objects based on the
+schema you have. Mashumaro not only lets you save and load things in different
+ways, but it also does it super quick.
+
+Key features:
+
+- One of the fastest libraries
+- Mature and time-tested
+- Easy to use out of the box
+- Highly customizable
+- Built-in support for JSON, YAML, MessagePack, TOML
+- Built-in support for almost all Python types including typing-extensions
+- JSON Schema generation