aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2022-06-08 13:17:27 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2022-06-08 13:17:27 +0000
commit0d7fa327fe1f4a6282efb372a28c80e188b5f5f9 (patch)
tree6fbdf5dbca0bbc4d90bcc877c8886b7a9d668f0f
parent84e3d7278502e0c812973b7daa22c4b290a03c73 (diff)
downloadports-0d7fa327fe1f4a6282efb372a28c80e188b5f5f9.tar.gz
ports-0d7fa327fe1f4a6282efb372a28c80e188b5f5f9.zip
devel/gdps: new port
General Purpose Data Serializer implemented as a very small C++ library, providing (de)serialization of C++ classes, via backends, such as XML. PR: 264530 Sponsored by: SkunkWerks, GmbH
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gpds/Makefile24
-rw-r--r--devel/gpds/distinfo3
-rw-r--r--devel/gpds/pkg-descr10
-rw-r--r--devel/gpds/pkg-plist16
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 48c1ecdcb908..bacba7513701 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -933,6 +933,7 @@
SUBDIR += goswagger
SUBDIR += got
SUBDIR += govendor
+ SUBDIR += gpds
SUBDIR += gperf
SUBDIR += gpm
SUBDIR += gputils
diff --git a/devel/gpds/Makefile b/devel/gpds/Makefile
new file mode 100644
index 000000000000..987101ea3527
--- /dev/null
+++ b/devel/gpds/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= gpds
+DISTVERSION= 1.5.0
+CATEGORIES= devel
+
+MAINTAINER= jbo@insane.engineer
+COMMENT= General purpose data serializer library written in modern C++
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+ONLY_FOR_ARCHS= aarch64 amd64
+ONLY_FOR_ARCHS_REASON= not yet ported to other architectures
+
+RUN_DEPENDS= spdlog>=1.9.0:devel/spdlog
+
+USES= cmake compiler:c++17-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= simulton
+
+CMAKE_OFF= GPDS_BUILD_EXAMPLES GPDS_BUILD_TESTS
+CMAKE_ON= GPDS_FEATURE_SPDLOG
+
+.include <bsd.port.mk>
diff --git a/devel/gpds/distinfo b/devel/gpds/distinfo
new file mode 100644
index 000000000000..57c1f06e20a0
--- /dev/null
+++ b/devel/gpds/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1654637835
+SHA256 (simulton-gpds-1.5.0_GH0.tar.gz) = 356e297bef7d990c354490f327e42d3c1e8b54bbac4bebdd0153752fde5ea2f1
+SIZE (simulton-gpds-1.5.0_GH0.tar.gz) = 840764
diff --git a/devel/gpds/pkg-descr b/devel/gpds/pkg-descr
new file mode 100644
index 000000000000..c6acba2040f4
--- /dev/null
+++ b/devel/gpds/pkg-descr
@@ -0,0 +1,10 @@
+GPDS is a General Purpose Data Serializer library written in modern C++.
+It allows to serialize C++ classes to and from XML files in a generic format
+that can be processed by other XML processing software (or just for the sake of
+readability).
+
+GPDS provides the user with complete control over the generated tag names and
+attributes in the resulting XML compared to just using traditional "key" and
+"value" tags.
+
+WWW: https://gpds.simulton.com/
diff --git a/devel/gpds/pkg-plist b/devel/gpds/pkg-plist
new file mode 100644
index 000000000000..82aa714783a6
--- /dev/null
+++ b/devel/gpds/pkg-plist
@@ -0,0 +1,16 @@
+include/gpds/archiver.hpp
+include/gpds/archiver_xml.hpp
+include/gpds/attributes.hpp
+include/gpds/container.hpp
+include/gpds/gpds_export.hpp
+include/gpds/serialize.hpp
+include/gpds/spdlog_sink.hpp
+include/gpds/utils.hpp
+include/gpds/value.hpp
+lib/cmake/gpds/gpds-config-version.cmake
+lib/cmake/gpds/gpds-config.cmake
+lib/cmake/gpds/gpds-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/gpds/gpds-targets.cmake
+lib/libgpds.a
+lib/libgpds.so
+lib/libgpds.so.1.5.0