aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-05-22 14:37:09 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-05-22 14:38:20 +0000
commit0df64b7edcfd318b7330084b702d21636de34d48 (patch)
tree3b664fb3c04dd1909effc12e23eda4ff785a99eb
parent9f910dd3a5fd6ce257801aeb809ae3fce67492d1 (diff)
downloadports-0df64b7edcfd318b7330084b702d21636de34d48.tar.gz
ports-0df64b7edcfd318b7330084b702d21636de34d48.zip
www/gitlab: added gmake and python as runtime dependency
the are required for the asset compilation
-rw-r--r--www/gitlab/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/gitlab/Makefile b/www/gitlab/Makefile
index 2b4b3be37543..601570b89eac 100644
--- a/www/gitlab/Makefile
+++ b/www/gitlab/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gitlab-${FLAVOR:Uce}
PORTVERSION= 17.0.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
.if ${FLAVOR:U} == ee
DISTVERSIONSUFFIX= -ee
.endif
@@ -307,12 +307,13 @@ MY_DEPENDS= git>=2.41.0:devel/git \
BUILD_DEPENDS= gem:devel/ruby-gems \
${MY_DEPENDS}
-RUN_DEPENDS= ${MY_DEPENDS}
+RUN_DEPENDS= gmake>=4.4.1:devel/gmake \
+ ${MY_DEPENDS}
FLAVORS= ce ee
FLAVOR?= ${FLAVORS:[1]}
-USES= nodejs:env ruby shebangfix
+USES= nodejs:env python:run ruby shebangfix
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org