aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2022-10-19 20:39:49 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-10-19 20:52:19 +0000
commit0e11ed94cdfe13f6588d4d067714ab8da1197204 (patch)
tree904a0b2de1d046bdd804b34f1e31d7e13f290e1c
parentde86c5fe2678752cf798a2fc3294fd13202eaae9 (diff)
downloadports-0e11ed94cdfe13f6588d4d067714ab8da1197204.tar.gz
ports-0e11ed94cdfe13f6588d4d067714ab8da1197204.zip
games/moonlight-embedded: Update to 2.5.3
Enable compiling a discover feature. (cherry picked from commit 17f6df6b7f53b17d2f2a0159a9b12a0c0e160c92)
-rw-r--r--games/moonlight-embedded/Makefile8
-rw-r--r--games/moonlight-embedded/distinfo6
-rw-r--r--games/moonlight-embedded/files/patch-src_main.c17
3 files changed, 7 insertions, 24 deletions
diff --git a/games/moonlight-embedded/Makefile b/games/moonlight-embedded/Makefile
index 3a0f43427f1a..f4e6a4716829 100644
--- a/games/moonlight-embedded/Makefile
+++ b/games/moonlight-embedded/Makefile
@@ -1,5 +1,5 @@
PORTNAME= moonlight-embedded
-DISTVERSION= 2.5.2
+DISTVERSION= 2.5.3
CATEGORIES= games
MASTER_SITES= https://github.com/irtimmer/moonlight-embedded/releases/download/v${DISTVERSION}/
@@ -11,7 +11,8 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
-LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
+LIB_DEPENDS= libavahi-client.so:net/avahi-app \
+ libavcodec.so:multimedia/ffmpeg \
libcurl.so:ftp/curl \
libenet.so:net/enet \
libexpat.so:textproc/expat2 \
@@ -34,10 +35,9 @@ post-patch:
-e '/libpulse-simple/d' \
-e '/libcec/d' \
${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e '/avahi-client/d' -e 's@SHARED@STATIC@' \
+ @${REINPLACE_CMD} -e 's@SHARED@STATIC@' \
-e 's@OpenSSL 1.0.2@OpenSSL@' -e '/^install(/d' \
${WRKSRC}/libgamestream/CMakeLists.txt
- @${RM} ${WRKSRC}/libgamestream/discover.c
@${REINPLACE_CMD} -e 's@/etc/moonlight/moonlight.conf@${PREFIX}/etc/moonlight.conf@' \
-e 's@moonligt@moonlight@g' \
${WRKSRC}/docs/README.pod
diff --git a/games/moonlight-embedded/distinfo b/games/moonlight-embedded/distinfo
index 119ac533be76..54aac4821a61 100644
--- a/games/moonlight-embedded/distinfo
+++ b/games/moonlight-embedded/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649611079
-SHA256 (moonlight-embedded-2.5.2.tar.xz) = 05b8c4db5ff4e5ea6f6edf2ffc35fef4c989792342549498fd372bc21707f809
-SIZE (moonlight-embedded-2.5.2.tar.xz) = 295184
+TIMESTAMP = 1666188557
+SHA256 (moonlight-embedded-2.5.3.tar.xz) = 2fcd00049f58b0af882f0eec7077013c062bc35c8705f3d6bb7949d44e98fac0
+SIZE (moonlight-embedded-2.5.3.tar.xz) = 303180
diff --git a/games/moonlight-embedded/files/patch-src_main.c b/games/moonlight-embedded/files/patch-src_main.c
deleted file mode 100644
index eb3340ad3460..000000000000
--- a/games/moonlight-embedded/files/patch-src_main.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/main.c.orig 2021-12-20 00:24:48 UTC
-+++ src/main.c
-@@ -258,12 +244,8 @@ int main(int argc, char* argv[]) {
- exit(-1);
- }
- config.address[0] = 0;
-- printf("Searching for server...\n");
-- gs_discover_server(config.address);
-- if (config.address[0] == 0) {
-- fprintf(stderr, "Autodiscovery failed. Specify an IP address next time.\n");
-- exit(-1);
-- }
-+ fprintf(stderr, "Autodiscovery unsupported. Specify an IP address next time.\n");
-+ exit(-1);
- }
-
- char host_config_file[128];