aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-30 03:24:10 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-30 03:24:10 +0000
commit0e13ed1591f687eac653f5c3109f43fb447ee34a (patch)
treec182b0a8d0b85545105e78593ef4a2ac664c21d8
parent03bf39e0763ca1a04e1bd96137ca9d3ded336ff8 (diff)
downloadports-0e13ed1591f687eac653f5c3109f43fb447ee34a.tar.gz
ports-0e13ed1591f687eac653f5c3109f43fb447ee34a.zip
security/py-iris-misp-module: New port: IRIS module interfacing MISP with IRIS
An interface module for MISP and Iris to automatically enrich IOCs with MISP insight.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-iris-misp-module/Makefile28
-rw-r--r--security/py-iris-misp-module/distinfo3
-rw-r--r--security/py-iris-misp-module/pkg-descr2
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 077ce83da8a1..cb49ee79523f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -916,6 +916,7 @@
SUBDIR += py-hkdf
SUBDIR += py-htpasswd
SUBDIR += py-iris-client
+ SUBDIR += py-iris-misp-module
SUBDIR += py-iris-module-interface
SUBDIR += py-itsdangerous
SUBDIR += py-josepy
diff --git a/security/py-iris-misp-module/Makefile b/security/py-iris-misp-module/Makefile
new file mode 100644
index 000000000000..8c4047cd1f41
--- /dev/null
+++ b/security/py-iris-misp-module/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= iris-misp-module
+DISTVERSION= 1.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= IRIS module interfacing MISP with IRIS
+WWW= https://github.com/dfir-iris/iris-module-interface
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyunpack>0:archivers/py-pyunpack@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}iris-module-interface>0:security/py-iris-module-interface@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pymisp>0:devel/py-pymisp@${PY_FLAVOR}
+
+USE_GITHUB= yes
+GH_ACCOUNT= dfir-iris
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= a7654c086bb163a97987698bae012c6bc05fd300
+
+USES= python:3.8+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-iris-misp-module/distinfo b/security/py-iris-misp-module/distinfo
new file mode 100644
index 000000000000..c2c72a87e4a6
--- /dev/null
+++ b/security/py-iris-misp-module/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680365667
+SHA256 (dfir-iris-iris-misp-module-v1.2.0-a7654c086bb163a97987698bae012c6bc05fd300_GH0.tar.gz) = c46d0d0e0a84e47c1e5f114b7d7a1da75216f0a3613e3c4bcee45ee5616298fd
+SIZE (dfir-iris-iris-misp-module-v1.2.0-a7654c086bb163a97987698bae012c6bc05fd300_GH0.tar.gz) = 21850
diff --git a/security/py-iris-misp-module/pkg-descr b/security/py-iris-misp-module/pkg-descr
new file mode 100644
index 000000000000..9e113a97f27f
--- /dev/null
+++ b/security/py-iris-misp-module/pkg-descr
@@ -0,0 +1,2 @@
+An interface module for MISP and Iris to automatically enrich IOCs with MISP
+insight.