aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 23:53:15 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 23:53:35 +0000
commit0e8f3671e89a72fdbfc4ff62fad620b4bbe83d47 (patch)
tree3479ea2b3d96ec3c5670733c8e2be29fbdf5d135
parent38014c3b12f4064e77d1b8fc9b1ac787e2ef270d (diff)
downloadports-0e8f3671e89a72fdbfc4ff62fad620b4bbe83d47.tar.gz
ports-0e8f3671e89a72fdbfc4ff62fad620b4bbe83d47.zip
devel/py-foolscap: Add I2P and TOR options
-rw-r--r--devel/py-foolscap/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/py-foolscap/Makefile b/devel/py-foolscap/Makefile
index fff46d072ae8..2e7c48b07e02 100644
--- a/devel/py-foolscap/Makefile
+++ b/devel/py-foolscap/Makefile
@@ -26,4 +26,11 @@ NO_ARCH= yes
TEST_ARGS= discover -s src
TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
+OPTIONS_DEFINE= I2P TOR
+I2P_DESC= I2P (Invisible Internet Project) support
+TOR_DESC= Tor support
+
+I2P_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}txi2p-tahoe>=0.3.5:devel/py-txi2p-tahoe@${PY_FLAVOR}
+TOR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}txtorcon>=19.0.0:security/py-txtorcon@${PY_FLAVOR}
+
.include <bsd.port.mk>