aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2021-09-28 06:53:45 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2021-09-28 06:55:29 +0000
commit0edd2574e1dc068d39919f3a64f2b8f585390abb (patch)
tree902efe04a376f6891111823a38ff4ead5f1b3bd2
parent3f4627fc27ad26876fdc440d51500c960f282751 (diff)
downloadports-0edd2574e1dc068d39919f3a64f2b8f585390abb.tar.gz
ports-0edd2574e1dc068d39919f3a64f2b8f585390abb.zip
databases/postgresql14-server: add support for lz4 compression
-rw-r--r--databases/postgresql14-server/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/databases/postgresql14-server/Makefile b/databases/postgresql14-server/Makefile
index a436a10c6837..6a10dd228b39 100644
--- a/databases/postgresql14-server/Makefile
+++ b/databases/postgresql14-server/Makefile
@@ -4,7 +4,7 @@ PORTNAME?= postgresql
DISTVERSION?= 14rc1
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= databases
MASTER_SITES= PGSQL/source/v${DISTVERSION}
PKGNAMESUFFIX?= ${PORTVERSION:R}${COMPONENT}
@@ -94,6 +94,14 @@ DTRACE_CONFIGURE_ENABLE=dtrace
DTRACE_LDFLAGS= -lelf
DTRACE_INSTALL_TARGET= install
+.if ${DISTVERSION:C/([0-9]*).*/\1/} >= 14
+OPTIONS_DEFINE+= LZ4
+OPTIONS_DEFAULT+= LZ4
+LZ4_DESC= Build with LZ4 compression support
+LZ4_CONFIGURE_WITH= lz4
+LZ4_LIB_DEPENDS+= liblz4.so:archivers/liblz4
+.endif
+
.if ${DISTVERSION:C/([0-9]*).*/\1/} >= 11
OPTIONS_DEFINE+= LLVM
OPTIONS_DEFAULT+= LLVM