aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:32:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:53:54 +0000
commit0f44ea4143781cff831954dbe9f2d9bca0640af5 (patch)
tree4770e6f8765d2fa774a3338d5765d7335fe4471f
parent70be34c9bb73ea7c16247e4edef1a197e441e504 (diff)
downloadports-0f44ea4143781cff831954dbe9f2d9bca0640af5.tar.gz
ports-0f44ea4143781cff831954dbe9f2d9bca0640af5.zip
devel/phpunit9: Add phpunit9 9.5.8
PHPUnit is a programmer-oriented testing framework for PHP. It is an instance of the xUnit architecture for unit testing frameworks. WWW: https://phpunit.de/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/phpunit9/Makefile31
-rw-r--r--devel/phpunit9/distinfo3
-rw-r--r--devel/phpunit9/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index be5ee8dc5676..d2ff59ec0c3e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3992,6 +3992,7 @@
SUBDIR += phpunit6
SUBDIR += phpunit7
SUBDIR += phpunit8
+ SUBDIR += phpunit9
SUBDIR += physfs
SUBDIR += pickle
SUBDIR += picojson
diff --git a/devel/phpunit9/Makefile b/devel/phpunit9/Makefile
new file mode 100644
index 000000000000..066eb85d6088
--- /dev/null
+++ b/devel/phpunit9/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= phpunit
+PORTVERSION= 9.5.8
+CATEGORIES= devel www
+MASTER_SITES= https://phar.phpunit.de/
+PKGNAMESUFFIX= 9${PHP_PKGNAMESUFFIX}
+EXTRACT_SUFX= .phar
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Testing framework for unit tests
+
+LICENSE= BSD3CLAUSE
+
+USES= cpe php:flavors
+USE_PHP= dom json pcre phar spl
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/phpunit
+
+CONFLICTS_INSTALL= phpunit6 phpunit7 phpunit8
+
+CPE_VENDOR= phpunit_project
+
+do-extract:
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/phpunit
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/phpunit ${STAGEDIR}${PREFIX}/bin/phpunit
+
+.include <bsd.port.mk>
diff --git a/devel/phpunit9/distinfo b/devel/phpunit9/distinfo
new file mode 100644
index 000000000000..d2975c76ab75
--- /dev/null
+++ b/devel/phpunit9/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1628103014
+SHA256 (phpunit-9.5.8.phar) = 11f27cf3f9522241fe234e9bf5813667207a074ac92089aac26d502ffc5e9517
+SIZE (phpunit-9.5.8.phar) = 4458067
diff --git a/devel/phpunit9/pkg-descr b/devel/phpunit9/pkg-descr
new file mode 100644
index 000000000000..8a05f03d4c7d
--- /dev/null
+++ b/devel/phpunit9/pkg-descr
@@ -0,0 +1,4 @@
+PHPUnit is a programmer-oriented testing framework for PHP. It is an instance of
+the xUnit architecture for unit testing frameworks.
+
+WWW: https://phpunit.de/