aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-05-14 15:06:42 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-05-16 18:22:56 +0000
commit0fb51ef88cf03579745135004621570a58998dfe (patch)
treea68a413bd7756e79ce0b213478ab735feb08e8ce
parent4f8b15b0e99c2325c0a0b2a07a39f4c01527c7d7 (diff)
downloadports-0fb51ef88cf03579745135004621570a58998dfe.tar.gz
ports-0fb51ef88cf03579745135004621570a58998dfe.zip
net/norm: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because net/norm's build system does not explicitly set the C++ standard, this leads to several errors: ../src/common/normEncoderRS8.cpp:264:5: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] USE_GF_MULC ; ^ ../src/common/normEncoderRS8.cpp:136:21: note: expanded from macro 'USE_GF_MULC' #define USE_GF_MULC register gf * __gf_mulc_ ^ ../src/common/normEncoderRS8.cpp:265:5: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register gf* dst = dst1; ^~~~~~~~~ ../src/common/normEncoderRS8.cpp:266:5: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register gf* src = src1 ; ^~~~~~~~~ Add USE_CXXSTD=gnu++98 to compile for C++98 with GNU extensions instead, as net/norm does not seem to use any C++11 or later constructs. PR: 271415 Approved by: portmgr (build fix blanket) MFH: 2023Q2
-rw-r--r--net/norm/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/norm/Makefile b/net/norm/Makefile
index 4c0cc829fd0a..ff9a233dd9a2 100644
--- a/net/norm/Makefile
+++ b/net/norm/Makefile
@@ -1,6 +1,6 @@
PORTNAME= norm
PORTVERSION= 1.5r6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://downloads.pf.itd.nrl.navy.mil/norm/archive/:norm \
https://waf.io/:waf
@@ -20,6 +20,7 @@ WWW= https://www.nrl.navy.mil/itd/ncs/products/norm
WRKSRC= ${WRKDIR}/norm-${DISTVERSION}
USES= libtool tar:tgz waf
+USE_CXXSTD= gnu++98
USE_LDCONFIG= yes
PLIST_FILES= include/normApi.h lib/libnorm.so lib/libnorm.so.1 \
lib/libnorm.so.1.0.0