aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-04 20:55:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-06 08:38:20 +0000
commit0fdaaf6891ae131165d8d6d7055d22f5e91ffd50 (patch)
tree74b87a3125ca509a190be7bd519abce5e54f2a71
parenteb066b7b991388004bbf7e2bb526bcd66807b6d7 (diff)
downloadports-0fdaaf6891ae131165d8d6d7055d22f5e91ffd50.tar.gz
ports-0fdaaf6891ae131165d8d6d7055d22f5e91ffd50.zip
graphics/vulkan-extension-layer: update to 1.2.187
-rw-r--r--graphics/vulkan-extension-layer/Makefile2
-rw-r--r--graphics/vulkan-extension-layer/distinfo6
-rw-r--r--graphics/vulkan-extension-layer/files/patch-headers-1.2.187103
3 files changed, 4 insertions, 107 deletions
diff --git a/graphics/vulkan-extension-layer/Makefile b/graphics/vulkan-extension-layer/Makefile
index 421e1e39f02f..a9015517fb87 100644
--- a/graphics/vulkan-extension-layer/Makefile
+++ b/graphics/vulkan-extension-layer/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vulkan-extension-layer
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.185
+DISTVERSION= 1.2.187
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org
diff --git a/graphics/vulkan-extension-layer/distinfo b/graphics/vulkan-extension-layer/distinfo
index 0fb508f8f83c..4096a8f4409c 100644
--- a/graphics/vulkan-extension-layer/distinfo
+++ b/graphics/vulkan-extension-layer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1625608724
-SHA256 (KhronosGroup-Vulkan-ExtensionLayer-v1.2.185_GH0.tar.gz) = 86e80ae16f80469a8746f1c98d2fac760e02d29aca2f9b9fd3142179985d8760
-SIZE (KhronosGroup-Vulkan-ExtensionLayer-v1.2.185_GH0.tar.gz) = 430806
+TIMESTAMP = 1628110546
+SHA256 (KhronosGroup-Vulkan-ExtensionLayer-v1.2.187_GH0.tar.gz) = 27a8190a76dd9bfef088bd357d37263d9f1bd63e21e3501e91ec6ed8176dbca7
+SIZE (KhronosGroup-Vulkan-ExtensionLayer-v1.2.187_GH0.tar.gz) = 430817
diff --git a/graphics/vulkan-extension-layer/files/patch-headers-1.2.187 b/graphics/vulkan-extension-layer/files/patch-headers-1.2.187
deleted file mode 100644
index bb5bd50911fa..000000000000
--- a/graphics/vulkan-extension-layer/files/patch-headers-1.2.187
+++ /dev/null
@@ -1,103 +0,0 @@
-Part of https://github.com/KhronosGroup/Vulkan-ValidationLayers/pull/3121
-
-In file included from layers/synchronization2.cpp:33:
-utils/generated/vk_safe_struct.h:3503:5: error: unknown type name 'VkVideoCapabilitiesFlagsKHR'; did you mean 'VkVideoCapabilityFlagsKHR'?
- VkVideoCapabilitiesFlagsKHR capabilityFlags;
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~
- VkVideoCapabilityFlagsKHR
-/usr/local/include/vulkan/vulkan_beta.h:74:17: note: 'VkVideoCapabilityFlagsKHR' declared here
-typedef VkFlags VkVideoCapabilityFlagsKHR;
- ^
-In file included from layers/synchronization2.cpp:33:
-utils/generated/vk_safe_struct.h:5546:5: error: unknown type name 'VkVideoEncodeH264CapabilitiesFlagsEXT'; did you mean 'VkVideoEncodeH264CapabilityFlagsEXT'?
- VkVideoEncodeH264CapabilitiesFlagsEXT flags;
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- VkVideoEncodeH264CapabilityFlagsEXT
-/usr/local/include/vulkan/vulkan_beta.h:453:17: note: 'VkVideoEncodeH264CapabilityFlagsEXT' declared here
-typedef VkFlags VkVideoEncodeH264CapabilityFlagsEXT;
- ^
-In file included from layers/synchronization2.cpp:33:
-utils/generated/vk_safe_struct.h:5735:5: error: unknown type name 'VkVideoDecodeH264FieldLayoutFlagsEXT'; did you mean 'VkVideoDecodeH264PictureLayoutFlagsEXT'?
- VkVideoDecodeH264FieldLayoutFlagsEXT fieldLayout;
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- VkVideoDecodeH264PictureLayoutFlagsEXT
-/usr/local/include/vulkan/vulkan_beta.h:579:17: note: 'VkVideoDecodeH264PictureLayoutFlagsEXT' declared here
-typedef VkFlags VkVideoDecodeH264PictureLayoutFlagsEXT;
- ^
-
---- utils/generated/vk_safe_struct.cpp.orig 2021-07-21 20:54:27 UTC
-+++ utils/generated/vk_safe_struct.cpp
-@@ -25624,7 +25624,7 @@ void safe_VkVideoEncodeH264ProfileEXT::initialize(cons
- safe_VkVideoDecodeH264ProfileEXT::safe_VkVideoDecodeH264ProfileEXT(const VkVideoDecodeH264ProfileEXT* in_struct) :
- sType(in_struct->sType),
- stdProfileIdc(in_struct->stdProfileIdc),
-- fieldLayout(in_struct->fieldLayout)
-+ pictureLayout(in_struct->pictureLayout)
- {
- pNext = SafePnextCopy(in_struct->pNext);
- }
-@@ -25638,7 +25638,7 @@ safe_VkVideoDecodeH264ProfileEXT::safe_VkVideoDecodeH2
- {
- sType = copy_src.sType;
- stdProfileIdc = copy_src.stdProfileIdc;
-- fieldLayout = copy_src.fieldLayout;
-+ pictureLayout = copy_src.pictureLayout;
- pNext = SafePnextCopy(copy_src.pNext);
- }
-
-@@ -25651,7 +25651,7 @@ safe_VkVideoDecodeH264ProfileEXT& safe_VkVideoDecodeH2
-
- sType = copy_src.sType;
- stdProfileIdc = copy_src.stdProfileIdc;
-- fieldLayout = copy_src.fieldLayout;
-+ pictureLayout = copy_src.pictureLayout;
- pNext = SafePnextCopy(copy_src.pNext);
-
- return *this;
-@@ -25667,7 +25667,7 @@ void safe_VkVideoDecodeH264ProfileEXT::initialize(cons
- {
- sType = in_struct->sType;
- stdProfileIdc = in_struct->stdProfileIdc;
-- fieldLayout = in_struct->fieldLayout;
-+ pictureLayout = in_struct->pictureLayout;
- pNext = SafePnextCopy(in_struct->pNext);
- }
-
-@@ -25675,7 +25675,7 @@ void safe_VkVideoDecodeH264ProfileEXT::initialize(cons
- {
- sType = copy_src->sType;
- stdProfileIdc = copy_src->stdProfileIdc;
-- fieldLayout = copy_src->fieldLayout;
-+ pictureLayout = copy_src->pictureLayout;
- pNext = SafePnextCopy(copy_src->pNext);
- }
- #endif // VK_ENABLE_BETA_EXTENSIONS
---- utils/generated/vk_safe_struct.h.orig 2021-07-21 20:54:27 UTC
-+++ utils/generated/vk_safe_struct.h
-@@ -3500,7 +3500,7 @@ struct safe_VkVideoProfilesKHR {
- struct safe_VkVideoCapabilitiesKHR {
- VkStructureType sType;
- void* pNext;
-- VkVideoCapabilitiesFlagsKHR capabilityFlags;
-+ VkVideoCapabilityFlagsKHR capabilityFlags;
- VkDeviceSize minBitstreamBufferOffsetAlignment;
- VkDeviceSize minBitstreamBufferSizeAlignment;
- VkExtent2D videoPictureExtentGranularity;
-@@ -5543,7 +5543,7 @@ struct safe_VkImageViewAddressPropertiesNVX {
- struct safe_VkVideoEncodeH264CapabilitiesEXT {
- VkStructureType sType;
- const void* pNext;
-- VkVideoEncodeH264CapabilitiesFlagsEXT flags;
-+ VkVideoEncodeH264CapabilityFlagsEXT flags;
- VkVideoEncodeH264InputModeFlagsEXT inputModeFlags;
- VkVideoEncodeH264OutputModeFlagsEXT outputModeFlags;
- VkExtent2D minPictureSizeInMbs;
-@@ -5732,7 +5732,7 @@ struct safe_VkVideoDecodeH264ProfileEXT {
- VkStructureType sType;
- const void* pNext;
- StdVideoH264ProfileIdc stdProfileIdc;
-- VkVideoDecodeH264FieldLayoutFlagsEXT fieldLayout;
-+ VkVideoDecodeH264PictureLayoutFlagsEXT pictureLayout;
- safe_VkVideoDecodeH264ProfileEXT(const VkVideoDecodeH264ProfileEXT* in_struct);
- safe_VkVideoDecodeH264ProfileEXT(const safe_VkVideoDecodeH264ProfileEXT& copy_src);
- safe_VkVideoDecodeH264ProfileEXT& operator=(const safe_VkVideoDecodeH264ProfileEXT& copy_src);