aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2023-07-20 17:05:38 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2023-07-20 17:05:38 +0000
commit0ff8163865567ad705b0f465a00ba72c8fa6ba3e (patch)
tree6f2785e2627ff0e769e2ccdfef95159d45e55b59
parent1d2661d84c368c19e33b3af3c11ca22fd219706b (diff)
downloadports-0ff8163865567ad705b0f465a00ba72c8fa6ba3e.tar.gz
ports-0ff8163865567ad705b0f465a00ba72c8fa6ba3e.zip
net-mgmt/metronome: Fix build with clang-16.x
-rw-r--r--net-mgmt/metronome/Makefile2
-rw-r--r--net-mgmt/metronome/files/patch-iputils.hh11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/metronome/Makefile b/net-mgmt/metronome/Makefile
index 0d87faa828a8..df85123ff01b 100644
--- a/net-mgmt/metronome/Makefile
+++ b/net-mgmt/metronome/Makefile
@@ -1,6 +1,6 @@
PORTNAME= metronome
DISTVERSION= 0.9.0
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= net-mgmt dns
MAINTAINER= krion@FreeBSD.org
diff --git a/net-mgmt/metronome/files/patch-iputils.hh b/net-mgmt/metronome/files/patch-iputils.hh
new file mode 100644
index 000000000000..4f23138c8ca1
--- /dev/null
+++ b/net-mgmt/metronome/files/patch-iputils.hh
@@ -0,0 +1,11 @@
+--- iputils.hh.orig 2023-07-20 17:03:02 UTC
++++ iputils.hh
+@@ -89,7 +89,7 @@ union ComboAddress {
+ return memcmp(&sin6.sin6_addr.s6_addr, &rhs.sin6.sin6_addr.s6_addr, 16) > 0;
+ }
+
+- struct addressOnlyLessThan: public std::binary_function<string, string, bool>
++ struct addressOnlyLessThan: public std::__binary_function<string, string, bool>
+ {
+ bool operator()(const ComboAddress& a, const ComboAddress& b) const
+ {