aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-10-02 16:36:01 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-10-02 17:01:36 +0000
commit104cc29607554a81cbb8d1e3b28721a87e190bf8 (patch)
tree64faf64be6d79e6c931d9bb117d15aef0e6154f8
parentb736288ff0e0aec0932ed931017bc8170c43b502 (diff)
downloadports-104cc29607554a81cbb8d1e3b28721a87e190bf8.tar.gz
ports-104cc29607554a81cbb8d1e3b28721a87e190bf8.zip
math/openturns: remove a deprecated option to chase ceres-solver 2.2.0
PR: 274203 Approved by: yuri (maintainer)
-rw-r--r--math/openturns/Makefile2
-rw-r--r--math/openturns/files/patch-lib_src_Base_Optim_Ceres.cxx11
2 files changed, 12 insertions, 1 deletions
diff --git a/math/openturns/Makefile b/math/openturns/Makefile
index 9a5ccf95598d..16067f989730 100644
--- a/math/openturns/Makefile
+++ b/math/openturns/Makefile
@@ -1,7 +1,7 @@
PORTNAME= openturns
DISTVERSIONPREFIX= v
DISTVERSION= 1.20
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/openturns/files/patch-lib_src_Base_Optim_Ceres.cxx b/math/openturns/files/patch-lib_src_Base_Optim_Ceres.cxx
new file mode 100644
index 000000000000..5ac32fa5dc58
--- /dev/null
+++ b/math/openturns/files/patch-lib_src_Base_Optim_Ceres.cxx
@@ -0,0 +1,11 @@
+--- lib/src/Base/Optim/Ceres.cxx.orig 2022-11-08 10:49:19 UTC
++++ lib/src/Base/Optim/Ceres.cxx
+@@ -341,8 +341,6 @@ void Ceres::run()
+ throw InvalidArgumentException(HERE) << "Invalid value for sparse_linear_algebra_library_type";
+ if (ResourceMap::HasKey("Ceres-use_explicit_schur_complement"))
+ options.use_explicit_schur_complement = ResourceMap::GetAsBool("Ceres-use_explicit_schur_complement");
+- if (ResourceMap::HasKey("Ceres-use_postordering"))
+- options.use_postordering = ResourceMap::GetAsBool("Ceres-use_postordering");
+ if (ResourceMap::HasKey("Ceres-dynamic_sparsity"))
+ options.dynamic_sparsity = ResourceMap::GetAsBool("Ceres-dynamic_sparsity");
+ if (ResourceMap::HasKey("Ceres-min_linear_solver_iterations"))