aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-23 14:15:42 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-23 14:22:31 +0000
commit105ff678258c186d4323e28977e503537ab3809e (patch)
treea1903ab8931785780e55364784b5b69c27cd63db
parentf5f521fe3be60cf74917aec00df1fa76098b7262 (diff)
downloadports-105ff678258c186d4323e28977e503537ab3809e.tar.gz
ports-105ff678258c186d4323e28977e503537ab3809e.zip
lang/php74: Update version 7.4.26=>7.4.27
- Refactor with OPTIONSNG Changelog: Core: Fixed bug #81626 (Error on use static:: in __сallStatic() wrapped to Closure::fromCallable()). FPM: Fixed bug #81513 (Future possibility for heap overflow in FPM zlog). GD: Fixed bug #71316 (libpng warning from imagecreatefromstring). OpenSSL: Fixed bug #75725 (./configure: detecting RAND_egd). PCRE: Fixed bug #74604 (Out of bounds in php_pcre_replace_impl). Standard: Fixed bug #81618 (dns_get_record fails on FreeBSD for missing type). Fixed bug #81659 (stream_get_contents() may unnecessarily overallocate). Approved by: tz (private mail) Relnotes: https://www.php.net/ChangeLog-7.php#7.4.27 Sponsored by: Bounce Experts
-rw-r--r--lang/php74/Makefile97
-rw-r--r--lang/php74/distinfo6
-rw-r--r--lang/php74/files/patch-ext_standard_dns.c21
-rw-r--r--lang/php74/files/patch-ext_standard_php__dns.h24
4 files changed, 33 insertions, 115 deletions
diff --git a/lang/php74/Makefile b/lang/php74/Makefile
index aad4738fc797..6ea41959830e 100644
--- a/lang/php74/Makefile
+++ b/lang/php74/Makefile
@@ -1,5 +1,5 @@
PORTNAME= php74
-DISTVERSION= 7.4.26
+DISTVERSION= 7.4.27
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
@@ -43,22 +43,42 @@ OPTIONS_EXCLUDE_armv7= DTRACE
# Bug 197128: No ASM code for MIPS/MIPS64, disable FPM
OPTIONS_EXCLUDE_mips= DTRACE FPM
OPTIONS_EXCLUDE_mips64= DTRACE FPM
-OPTIONS_EXCLUDE_powerpc64= ${OPTIONS_EXCLUDE_${ARCH}_${OSREL:R}}
-OPTIONS_EXCLUDE_powerpc64_11= DTRACE
+OPTIONS_EXCLUDE_powerpc64= ${OPTIONS_EXCLUDE_${ARCH}_${OSREL:R}}
+OPTIONS_EXCLUDE_powerpc64_11= DTRACE
OPTIONS_EXCLUDE_powerpc64_12= DTRACE
OPTIONS_EXCLUDE_riscv64= DTRACE
OPTIONS_EXCLUDE_sparc64= DTRACE
OPTIONS_SUB= yes
-CLI_DESC= Build CLI version
CGI_DESC= Build CGI version
-FPM_DESC= Build FPM version
+CLI_DESC= Build CLI version
EMBED_DESC= Build embedded library
-PHPDBG_DESC= Interactive PHP debugger
-MYSQLND_DESC= Build with MySQL Native Driver
+FPM_DESC= Build FPM version
LINKTHR_DESC= Link thread lib (for threaded extensions)
+MYSQLND_DESC= Build with MySQL Native Driver
+PHPDBG_DESC= Interactive PHP debugger
ZTS_DESC= Force Zend Thread Safety (ZTS) build
+CGI_CONFIGURE_OFF=--disable-cgi
+CGI_VARS= PHP_SAPI+=cgi
+CLI_CONFIGURE_OFF=--disable-cli
+CLI_VARS= PHP_SAPI+=cli
+DEBUG_CONFIGURE_ON=--enable-debug
+DTRACE_CONFIGURE_ON=--enable-dtrace
+EMBED_CONFIGURE_ON=--enable-embed
+EMBED_VARS= PHP_SAPI+=embed
+FPM_CONFIGURE_ON=--enable-fpm \
+ --with-fpm-user=${WWWOWN} \
+ --with-fpm-group=${WWWGRP}
+FPM_VARS= PHP_SAPI+=fpm USE_RC_SUBR+=php-fpm
+IPV6_CONFIGURE_OFF=--disable-ipv6
+LINKTHR_LIBS= -lpthread
+MYSQLND_CONFIGURE_ON=--enable-mysqlnd
+PHPDBG_CONFIGURE_ON=--enable-phpdbg
+PHPDBG_VARS= PHP_SAPI+=phpdbg
+ZTS_CONFIGURE_ENV= pthreads_working="yes"
+ZTS_CONFIGURE_ON=--enable-maintainer-zts
+
CONFLICTS= php73 php80
DESTDIRNAME= INSTALL_ROOT
@@ -69,30 +89,6 @@ DESTDIRNAME= INSTALL_ROOT
CONFIGURE_ARGS+=--without-pcre-jit
.endif
-.if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--enable-mysqlnd
-.endif
-
-.if ${PORT_OPTIONS:MCLI}
-PHP_SAPI+= cli
-.else
-CONFIGURE_ARGS+=--disable-cli
-.endif
-
-.if ${PORT_OPTIONS:MCGI}
-PHP_SAPI+= cgi
-.else
-CONFIGURE_ARGS+=--disable-cgi
-.endif
-
-.if ${PORT_OPTIONS:MFPM}
-PHP_SAPI+= fpm
-USE_RC_SUBR+= php-fpm
-CONFIGURE_ARGS+=--enable-fpm \
- --with-fpm-user=${WWWOWN} \
- --with-fpm-group=${WWWGRP}
-.endif
-
.if defined(PKGNAMEPREFIX)
USES+= apache:2.2+
.include "${PORTSDIR}/Mk/Uses/apache.mk"
@@ -108,18 +104,9 @@ SHORTMODNAME= php7
WARNING= "!!! If you have a threaded Apache, you must build ${PHP_PORT} with ZTS support to enable thread-safety in extensions !!!"
.endif
-.if ${PORT_OPTIONS:MEMBED}
-PHP_SAPI+= embed
-CONFIGURE_ARGS+=--enable-embed
-.endif
-
-.if ${PORT_OPTIONS:MPHPDBG}
-PHP_SAPI+= phpdbg
-CONFIGURE_ARGS+=--enable-phpdbg
-.if ${PORT_OPTIONS:MDEBUG}
+.if ${PORT_OPTIONS:MPHPDBG} && ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-phpdbg-debug
.endif
-.endif
.if ${PORT_OPTIONS:MCLI} || ${PORT_OPTIONS:MEMBED}
PLIST_SUB+= SAPI_INC=""
@@ -130,37 +117,13 @@ PLIST_SUB+= SAPI_INC="@comment "
CONFIGURE_ENV+= ac_cv_decimal_fp_supported="no" \
lt_cv_path_SED="sed"
-.if ${PORT_OPTIONS:MLINKTHR}
-LIBS+= -lpthread
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--enable-debug
-.endif
-
-.if ${PORT_OPTIONS:MZTS}
-CONFIGURE_ARGS+=--enable-maintainer-zts
-CONFIGURE_ENV+= pthreads_working="yes"
-.endif
-
-.if ${PORT_OPTIONS:MDTRACE}
-CONFIGURE_ARGS+=--enable-dtrace
-PLIST_SUB+= DTRACE=""
-.else
-PLIST_SUB+= DTRACE="@comment "
-.endif
-
-.if empty(PORT_OPTIONS:MIPV6)
-CONFIGURE_ARGS+=--disable-ipv6
-.endif
-
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
-.if ${PORT_OPTIONS:MFPM}
+
+post-patch-FPM-on:
@${REINPLACE_CMD} -e "s|^;\(pid\)|\1|;s|^;\(pm\.[a-z_]*_servers\)|\1|" \
${WRKSRC}/sapi/fpm/php-fpm.conf.in
-.endif
pre-configure:
@(cd ${WRKSRC} && ${SETENV} MAKE=${MAKE_CMD} ./buildconf --force)
diff --git a/lang/php74/distinfo b/lang/php74/distinfo
index 0c166044ea81..be3754334520 100644
--- a/lang/php74/distinfo
+++ b/lang/php74/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637348951
-SHA256 (php-7.4.26.tar.xz) = e305b3aafdc85fa73a81c53d3ce30578bc94d1633ec376add193a1e85e0f0ef8
-SIZE (php-7.4.26.tar.xz) = 10420236
+TIMESTAMP = 1640242507
+SHA256 (php-7.4.27.tar.xz) = 3f8b937310f155822752229c2c2feb8cc2621e25a728e7b94d0d74c128c43d0c
+SIZE (php-7.4.27.tar.xz) = 10419380
diff --git a/lang/php74/files/patch-ext_standard_dns.c b/lang/php74/files/patch-ext_standard_dns.c
deleted file mode 100644
index 19e539a41b1e..000000000000
--- a/lang/php74/files/patch-ext_standard_dns.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- ext/standard/dns.c.orig 2021-10-19 15:18:17 UTC
-+++ ext/standard/dns.c
-@@ -808,6 +808,7 @@ PHP_FUNCTION(dns_get_record)
- zend_long type_param = PHP_DNS_ANY;
- zval *authns = NULL, *addtl = NULL;
- int type_to_fetch;
-+ int dns_errno;
- #if defined(HAVE_DNS_SEARCH)
- struct sockaddr_storage from;
- uint32_t fromsize = sizeof(from);
-@@ -957,8 +958,9 @@ PHP_FUNCTION(dns_get_record)
- n = php_dns_search(handle, hostname, C_IN, type_to_fetch, answer.qb2, sizeof answer);
-
- if (n < 0) {
-+ dns_errno = php_dns_errno(handle);
- php_dns_free_handle(handle);
-- switch (h_errno) {
-+ switch (dns_errno) {
- case NO_DATA:
- case HOST_NOT_FOUND:
- continue;
diff --git a/lang/php74/files/patch-ext_standard_php__dns.h b/lang/php74/files/patch-ext_standard_php__dns.h
deleted file mode 100644
index 4fadb68eda60..000000000000
--- a/lang/php74/files/patch-ext_standard_php__dns.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- ext/standard/php_dns.h.orig 2021-10-19 15:18:17 UTC
-+++ ext/standard/php_dns.h
-@@ -26,6 +26,7 @@
- ((int)dns_search(res, dname, class, type, (char *) answer, anslen, (struct sockaddr *)&from, &fromsize))
- #define php_dns_free_handle(res) \
- dns_free(res)
-+#define php_dns_errno(handle) h_errno
-
- #elif defined(HAVE_RES_NSEARCH)
- #define php_dns_search(res, dname, class, type, answer, anslen) \
-@@ -39,11 +40,13 @@
- res_nclose(res); \
- php_dns_free_res(res)
- #endif
-+#define php_dns_errno(handle) handle->res_h_errno
-
- #elif defined(HAVE_RES_SEARCH)
- #define php_dns_search(res, dname, class, type, answer, anslen) \
- res_search(dname, class, type, answer, anslen)
- #define php_dns_free_handle(res) /* noop */
-+#define php_dns_errno(handle) h_errno
-
- #endif
-