aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:40:44 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:10 +0000
commit1219e75f3498da4e77856b3dbbd56809c3481b60 (patch)
treea5a542f35a6f3b917d08ab65f87eb91b307532f4
parentddddb7da7783264317d4feb07e67002cdee0a227 (diff)
downloadports-1219e75f3498da4e77856b3dbbd56809c3481b60.tar.gz
ports-1219e75f3498da4e77856b3dbbd56809c3481b60.zip
textproc/zenxml: Update to 2.5
- Update COMMENT - Update WWW - Add LICENSE_FILE - Remove USES=dos2unix - Update pkg-descr - Take maintainership
-rw-r--r--textproc/zenxml/Makefile31
-rw-r--r--textproc/zenxml/distinfo6
-rw-r--r--textproc/zenxml/pkg-descr11
-rw-r--r--textproc/zenxml/pkg-plist35
4 files changed, 50 insertions, 33 deletions
diff --git a/textproc/zenxml/Makefile b/textproc/zenxml/Makefile
index 32851796f5f4..e8044c9c97b6 100644
--- a/textproc/zenxml/Makefile
+++ b/textproc/zenxml/Makefile
@@ -1,36 +1,25 @@
PORTNAME= zenxml
-PORTVERSION= 2.4
+PORTVERSION= 2.5
CATEGORIES= textproc
-MASTER_SITES= SF/${PORTNAME}/
+MASTER_SITES= SF/zenxml
DISTNAME= zenXml_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Simple XML processing using C++
-WWW= http://zenxml.sourceforge.net/
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple C++ XML Processing
+WWW= https://zenxml.sourceforge.net/
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/License.txt
-USES= dos2unix zip
+USES= zip
NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-ZENINC= ${PREFIX}/include/${PORTNAME:S/xml//}
-
-OPTIONS_DEFINE= DOCS
-
-PORTDOCS= *
-
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
- @${MKDIR} ${STAGEDIR}${ZENINC}
- cd ${WRKSRC}/${PORTNAME} && \
- ${COPYTREE_SHARE} \*.h ${STAGEDIR}${PREFIX}/include/${PORTNAME}
- cd ${WRKSRC}/${PORTNAME:S/xml//} && \
- ${COPYTREE_SHARE} \*.h ${STAGEDIR}${ZENINC}
-
-do-install-DOCS-on:
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/zen/ ${STAGEDIR}${PREFIX}/include/zenxml/
+ ${INSTALL_DATA} ${WRKSRC}/zen/*.h ${STAGEDIR}${PREFIX}/include/zen/
+ ${INSTALL_DATA} ${WRKSRC}/zenxml/*.h ${STAGEDIR}${PREFIX}/include/zenxml/
.include <bsd.port.mk>
diff --git a/textproc/zenxml/distinfo b/textproc/zenxml/distinfo
index 286dcc017dc2..e40b099cfc9b 100644
--- a/textproc/zenxml/distinfo
+++ b/textproc/zenxml/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518318204
-SHA256 (zenXml_2.4.zip) = 881de299f77017f8c20e05092ef41c7963e20928b63b431fe14cc4597948cc68
-SIZE (zenXml_2.4.zip) = 272101
+TIMESTAMP = 1677771051
+SHA256 (zenXml_2.5.zip) = 0231b2f2ac27edd45142d10861d094c22de31474f84b97781d276d33e1841c6e
+SIZE (zenXml_2.5.zip) = 368610
diff --git a/textproc/zenxml/pkg-descr b/textproc/zenxml/pkg-descr
index 90c4cabf3e9d..1ab28a5aecf0 100644
--- a/textproc/zenxml/pkg-descr
+++ b/textproc/zenxml/pkg-descr
@@ -1,4 +1,7 @@
-Zenxml is an XML library serializing structured user data in a convenient
-way. Using compile-time information gathered by techniques of template
-metaprogramming it minimizes the manual overhead required and frees the
-user from implementing fundamental type conversions by himself.
+zen::Xml is an XML library serializing structured user data in a convenient way.
+Using compile-time information gathered by techniques of template
+metaprogramming it minimizes the manual overhead required and frees the user
+from implementing fundamental type conversions by himself.
+
+zen::Xml is written in a platform independent manner and runs on any
+C++14-compliant compiler.
diff --git a/textproc/zenxml/pkg-plist b/textproc/zenxml/pkg-plist
index a264bc307db7..b5d75765a8a8 100644
--- a/textproc/zenxml/pkg-plist
+++ b/textproc/zenxml/pkg-plist
@@ -1,16 +1,41 @@
-include/zen/fixed_list.h
+include/zen/base64.h
+include/zen/basic_math.h
+include/zen/build_info.h
+include/zen/crc.h
+include/zen/file_access.h
+include/zen/file_error.h
+include/zen/file_io.h
+include/zen/file_path.h
+include/zen/file_traverser.h
+include/zen/format_unit.h
+include/zen/globals.h
+include/zen/guid.h
+include/zen/i18n.h
+include/zen/json.h
+include/zen/legacy_compiler.h
+include/zen/perf.h
+include/zen/recycler.h
+include/zen/resolve_path.h
+include/zen/ring_buffer.h
include/zen/scope_guard.h
+include/zen/serialize.h
include/zen/stl_tools.h
+include/zen/stream_buffer.h
+include/zen/string_base.h
include/zen/string_tools.h
include/zen/string_traits.h
-include/zen/type_tools.h
+include/zen/symlink_target.h
+include/zen/sys_error.h
+include/zen/sys_info.h
+include/zen/sys_version.h
+include/zen/thread.h
+include/zen/time.h
include/zen/type_traits.h
include/zen/utf.h
-include/zenxml/bind.h
+include/zen/warn_static.h
+include/zen/zstring.h
include/zenxml/cvrt_struc.h
include/zenxml/cvrt_text.h
include/zenxml/dom.h
-include/zenxml/error.h
-include/zenxml/io.h
include/zenxml/parser.h
include/zenxml/xml.h