aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-10-05 18:54:00 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-10-05 18:54:04 +0000
commit1271f7aecc958c600e4a01c65896281521015ff0 (patch)
tree1973532bb1f593bf1812b47a544c1ba0212f0c0d
parent9a36ff5299c8de0f7a97093fcfe88a2befc0fe35 (diff)
downloadports-1271f7aecc958c600e4a01c65896281521015ff0.tar.gz
ports-1271f7aecc958c600e4a01c65896281521015ff0.zip
net/astron: Disable compiler warnings as errors
Defining -DNDEBUG requires -Werror to be disabled for port to build PR: 266721 Reviewed by: nc (maintainer)
-rw-r--r--net/astron/files/patch-CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/net/astron/files/patch-CMakeLists.txt b/net/astron/files/patch-CMakeLists.txt
index dc67f43c69fa..470448dfcac5 100644
--- a/net/astron/files/patch-CMakeLists.txt
+++ b/net/astron/files/patch-CMakeLists.txt
@@ -1,5 +1,14 @@
---- CMakeLists.txt.orig 2021-04-06 22:45:16 UTC
+--- CMakeLists.txt.orig 2020-05-21 16:39:19 UTC
+++ CMakeLists.txt
+@@ -75,7 +75,7 @@ endif()
+ # Common flags:
+ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR
+ CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Werror -Wno-error=deprecated-declarations")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-error=deprecated-declarations")
+ endif()
+
+ # Clang-specific flags:
@@ -92,7 +92,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Windows") ### Windows
list(APPEND EXTRA_LIBS wsock32 ws2_32)
endif()