aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2021-11-24 13:52:00 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2021-11-24 13:52:17 +0000
commit127b1255616a89dd0df5fcdf3c6c131d6103657f (patch)
tree5e594116456d7541215816f4088620ad367bb201
parentbba8bcbcbd25f9c62c79c8b20f4bd709c345dc3f (diff)
downloadports-127b1255616a89dd0df5fcdf3c6c131d6103657f.tar.gz
ports-127b1255616a89dd0df5fcdf3c6c131d6103657f.zip
www/sitecopy: Allow build with neon >= 0.32
Fix build with neon >= 0.32 While at it, pet portlint PR: 259594 Approved by: mentors (implicit), maintainer timeout (3+ weeks)
-rw-r--r--www/sitecopy/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index 8d06c85b8548..16ca167c3f08 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -10,14 +10,16 @@ MASTER_SITES= http://www.manyfish.co.uk/${PORTNAME}/ \
MAINTAINER= sitecopy@oldach.net
COMMENT= Maintains remote websites, uses FTP or WebDAV to sync up w/ local copy
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libneon.so:www/neon
+USES= gmake gnome localbase
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+
CONFIGURE_ARGS= --with-neon --with-libxml2
-USE_GNOME= libxml2
-USES= gmake gnome
OPTIONS_DEFINE= NLS
@@ -40,7 +42,7 @@ CONFIGURE_ARGS+= --with-ssl
post-patch:
@${REINPLACE_CMD} -e 's|;;|;|g' \
${WRKSRC}/src/sitestore.c
- @${REINPLACE_CMD} -e 's|25 26 27 28|& 29 30 31|g' \
+ @${REINPLACE_CMD} -e 's|25 26 27 28|& 29 30 31 32|g' \
${WRKSRC}/configure
.if ${OPSYS} == FreeBSD
@${REINPLACE_CMD} -e '/#define ksize_t /d' \