aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-04-16 17:10:40 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-04-16 17:13:38 +0000
commit127b35f95fe7a23430a6bb8928bc24971d9af222 (patch)
treeda207d865723e5817c75427be68fba2ea8ca8455
parentab7dc9b008beb588417d5876d4bf11bbc15397fc (diff)
downloadports-127b35f95fe7a23430a6bb8928bc24971d9af222.tar.gz
ports-127b35f95fe7a23430a6bb8928bc24971d9af222.zip
deskutils/calibre: Update to 5.15
- Update patch, while here also fix patched conditional
-rw-r--r--deskutils/calibre/Makefile3
-rw-r--r--deskutils/calibre/distinfo6
-rw-r--r--deskutils/calibre/files/patch-src_calibre_utils_formatter.py11
-rw-r--r--deskutils/calibre/pkg-plist2
4 files changed, 12 insertions, 10 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index edd56eaeb714..250e760c3d46 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -1,8 +1,7 @@
# Created by: stas
PORTNAME= calibre
-PORTVERSION= 5.14.0
-PORTREVISION= 2
+PORTVERSION= 5.15.0
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index b79737bbd934..36feb7e194c5 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616750023
-SHA256 (calibre-5.14.0.tar.xz) = 186cce57b6990af0b014282fa1d3d914fffc11e40d8495ea43d91485534e1271
-SIZE (calibre-5.14.0.tar.xz) = 36712348
+TIMESTAMP = 1618554840
+SHA256 (calibre-5.15.0.tar.xz) = 9afb072ff8d0705bb214dac2532935bdef484ceb2741cdfef4136289ca44ba94
+SIZE (calibre-5.15.0.tar.xz) = 36751412
diff --git a/deskutils/calibre/files/patch-src_calibre_utils_formatter.py b/deskutils/calibre/files/patch-src_calibre_utils_formatter.py
index 581415a8cb95..64e1c737f4ba 100644
--- a/deskutils/calibre/files/patch-src_calibre_utils_formatter.py
+++ b/deskutils/calibre/files/patch-src_calibre_utils_formatter.py
@@ -1,11 +1,12 @@
---- src/calibre/utils/formatter.py.orig 2020-11-13 01:58:49 UTC
+--- src/calibre/utils/formatter.py.orig 2021-04-16 02:20:00 UTC
+++ src/calibre/utils/formatter.py
-@@ -536,7 +536,7 @@ class _Interpreter(object):
+@@ -888,7 +888,8 @@ class _Interpreter(object):
def do_node_first_non_empty(self, prog):
for expr in prog.expression_list:
- if v := self.expr(expr):
-+ if v == self.expr(expr):
++ v = self.expr(expr)
++ if v:
+ if (self.break_reporter):
+ self.break_reporter(prog.node_name, v, prog.line_number)
return v
-
- NODE_OPS = {
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 9d769d5875dd..31951eaa49d3 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -634,6 +634,7 @@ lib/calibre/calibre/gui2/actions/add.py
lib/calibre/calibre/gui2/actions/add_to_library.py
lib/calibre/calibre/gui2/actions/annotate.py
lib/calibre/calibre/gui2/actions/author_mapper.py
+lib/calibre/calibre/gui2/actions/auto_scroll.py
lib/calibre/calibre/gui2/actions/browse_annots.py
lib/calibre/calibre/gui2/actions/catalog.py
lib/calibre/calibre/gui2/actions/choose_library.py
@@ -832,6 +833,7 @@ lib/calibre/calibre/gui2/dialogs/tag_list_editor.py
lib/calibre/calibre/gui2/dialogs/tag_list_editor_table_widget.py
lib/calibre/calibre/gui2/dialogs/tag_list_editor_ui.py
lib/calibre/calibre/gui2/dialogs/template_dialog.py
+lib/calibre/calibre/gui2/dialogs/template_dialog_code_widget.py
lib/calibre/calibre/gui2/dialogs/template_dialog_ui.py
lib/calibre/calibre/gui2/dialogs/template_line_editor.py
lib/calibre/calibre/gui2/dialogs/trim_image.py