aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-08 20:13:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-08 20:16:54 +0000
commit12960c58c4e91db3965e79bdbbe9d43ce8691941 (patch)
tree57e4349a818c1ab9caafda0e6762d2f4c4aab92c
parent1e55e4ad78573d82c162527b4ccc694f99d3b023 (diff)
downloadports-12960c58c4e91db3965e79bdbbe9d43ce8691941.tar.gz
ports-12960c58c4e91db3965e79bdbbe9d43ce8691941.zip
devel/py-gevent: Update to 24.2.1
- Update WWW and clean up pkg-descr - Convert to USE_PYTHON=pep517 Changes: https://github.com/gevent/gevent/blob/master/CHANGES.rst https://www.gevent.org/changelog.html
-rw-r--r--devel/py-gevent/Makefile20
-rw-r--r--devel/py-gevent/distinfo6
-rw-r--r--devel/py-gevent/pkg-descr2
3 files changed, 17 insertions, 11 deletions
diff --git a/devel/py-gevent/Makefile b/devel/py-gevent/Makefile
index 6794da9466f8..fc7c2bc3da29 100644
--- a/devel/py-gevent/Makefile
+++ b/devel/py-gevent/Makefile
@@ -1,12 +1,14 @@
PORTNAME= gevent
-PORTVERSION= 22.10.2
+PORTVERSION= 24.2.1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python co-routine networking library based on greenlet
-WWW= https://www.gevent.org/
+WWW= https://www.gevent.org/ \
+ https://python-gevent.readthedocs.io/ \
+ https://github.com/gevent/gevent
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -14,19 +16,25 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= c-ares>=1.15.0:dns/c-ares \
libev>=4.31:devel/libev \
libuv>=1.34.0:devel/libuv \
- ${RUN_DEPENDS}
+ ${PYTHON_PKGNAMEPREFIX}cffi>=1.12.3:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cython3>=3.0.8:lang/cython3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}greenlet>=3.0.3:devel/py-greenlet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=40.8.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libcares.so:dns/c-ares \
libev.so:devel/libev \
libuv.so:devel/libuv
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}greenlet>=2.0.0:devel/py-greenlet@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.12.3:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}greenlet>=3.0.3:devel/py-greenlet@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zope.event>=0:devel/py-zope.event@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR}
USES= compiler:c11 localbase python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
MAKE_ENV= GEVENTSETUP_EMBED_CARES=0 GEVENTSETUP_EMBED_LIBEV=0 GEVENTSETUP_EMBED_LIBUV=0
+TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
post-patch:
@${RM} ${WRKSRC}/src/gevent/_util_py2.py
@@ -37,6 +45,6 @@ post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
do-test:
- cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} ${PYTHON_CMD} -m gevent.tests --config known_failures.py
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m gevent.tests
.include <bsd.port.mk>
diff --git a/devel/py-gevent/distinfo b/devel/py-gevent/distinfo
index f578ef28d62e..390995493974 100644
--- a/devel/py-gevent/distinfo
+++ b/devel/py-gevent/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669057739
-SHA256 (gevent-22.10.2.tar.gz) = 1ca01da176ee37b3527a2702f7d40dbc9ffb8cfc7be5a03bfa4f9eec45e55c46
-SIZE (gevent-22.10.2.tar.gz) = 6551607
+TIMESTAMP = 1712580508
+SHA256 (gevent-24.2.1.tar.gz) = 432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056
+SIZE (gevent-24.2.1.tar.gz) = 6147507
diff --git a/devel/py-gevent/pkg-descr b/devel/py-gevent/pkg-descr
index 23a0f8be7422..6359cd7312b2 100644
--- a/devel/py-gevent/pkg-descr
+++ b/devel/py-gevent/pkg-descr
@@ -14,5 +14,3 @@ Features include:
gevent is inspired by eventlet but features more consistent API, simpler
implementation and better performance. Read why others use gevent and check out
the list of the open source projects based on gevent.
-
-See also: https://github.com/gevent/gevent