aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2023-04-04 16:50:24 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2023-04-04 16:50:24 +0000
commit12b470f101e0492a9ec06d185f7d347a94f06495 (patch)
tree090c6e59d67e70167c3071be728370311e37c2c3
parente067517f4e096d82d5258b598a515e7f7794d470 (diff)
downloadports-12b470f101e0492a9ec06d185f7d347a94f06495.tar.gz
ports-12b470f101e0492a9ec06d185f7d347a94f06495.zip
textproc/py-python-lsp-server: Update to 1.7.2
-rw-r--r--textproc/py-python-lsp-server/Makefile6
-rw-r--r--textproc/py-python-lsp-server/distinfo6
-rw-r--r--textproc/py-python-lsp-server/files/patch-pyproject.toml29
3 files changed, 21 insertions, 20 deletions
diff --git a/textproc/py-python-lsp-server/Makefile b/textproc/py-python-lsp-server/Makefile
index 5f5ba3614732..5211514946c3 100644
--- a/textproc/py-python-lsp-server/Makefile
+++ b/textproc/py-python-lsp-server/Makefile
@@ -1,5 +1,5 @@
PORTNAME= python-lsp-server
-PORTVERSION= 1.7.1
+PORTVERSION= 1.7.2
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -43,8 +43,8 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}yapf>0:textproc/py-yapf@${PY_FLAVOR} \
${PYNUMPY}
-# make test: 6 failed, 161 passed, 8 skipped, 21 warnings
-# devel/py-pydocstyle v6.3.0 is too new atm :(
+# make test: 3 failed, 168 passed, 8 skipped, 21 warnings
+# test/plugins/test_flake8_lint.py:90,219,241: AssertionError
USES= python:3.7+ pytest
USE_PYTHON= autoplist concurrent pep517
diff --git a/textproc/py-python-lsp-server/distinfo b/textproc/py-python-lsp-server/distinfo
index 38d2655e7967..0f3ea261c36b 100644
--- a/textproc/py-python-lsp-server/distinfo
+++ b/textproc/py-python-lsp-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679647676
-SHA256 (python-lsp-server-1.7.1.tar.gz) = 67473bb301f35434b5fa8b21fc5ed5fac27dc8a8446ccec8bae456af52a0aef6
-SIZE (python-lsp-server-1.7.1.tar.gz) = 95731
+TIMESTAMP = 1680625275
+SHA256 (python-lsp-server-1.7.2.tar.gz) = b2433467d0fcb8fd45828463ff1cc805837c08731fcea5d7d953d9be776881e1
+SIZE (python-lsp-server-1.7.2.tar.gz) = 97050
diff --git a/textproc/py-python-lsp-server/files/patch-pyproject.toml b/textproc/py-python-lsp-server/files/patch-pyproject.toml
index ff7f0f829b98..daa45ceb646a 100644
--- a/textproc/py-python-lsp-server/files/patch-pyproject.toml
+++ b/textproc/py-python-lsp-server/files/patch-pyproject.toml
@@ -1,42 +1,43 @@
---- pyproject.toml.orig 2023-01-06 23:50:19 UTC
+--- pyproject.toml.orig 2023-03-18 18:10:05 UTC
+++ pyproject.toml
-@@ -27,26 +27,26 @@ all = [
+@@ -27,27 +27,27 @@ all = [
[project.optional-dependencies]
all = [
-- "autopep8>=1.6.0,<1.7.0",
+- "autopep8>=1.6.0,<2.1.0",
- "flake8>=5.0.0,<7",
- "mccabe>=0.7.0,<0.8.0",
- "pycodestyle>=2.9.0,<2.11.0",
-- "pydocstyle>=6.2.0,<6.3.0",
-- "pyflakes>=2.5.0,<3.1.0",
+- "pydocstyle>=6.3.0,<6.4.0",
+ "autopep8>=1.6.0",
+ "flake8>=5.0.0",
+ "mccabe>=0.7.0",
+ "pycodestyle>=2.9.0",
-+ "pydocstyle>=6.2.0",
-+ "pyflakes>=2.5.0",
- "pylint>=2.5.0,<3",
++ "pydocstyle>=6.3.0",
+ "pyflakes>=2.5.0,<3.1.0",
+- "pylint>=2.5.0,<3",
++ "pylint>=2.5.0",
"rope>1.2.0",
- "yapf",
+ "yapf<=0.32.0",
+ "toml",
"whatthepatch>=1.0.2,<2.0.0"
]
--autopep8 = ["autopep8>=1.6.0,<1.7.0"]
+-autopep8 = ["autopep8>=1.6.0,<2.1.0"]
-flake8 = ["flake8>=5.0.0,<7"]
-mccabe = ["mccabe>=0.7.0,<0.8.0"]
-pycodestyle = ["pycodestyle>=2.9.0,<2.11.0"]
--pydocstyle = ["pydocstyle>=6.2.0,<6.3.0"]
+-pydocstyle = ["pydocstyle>=6.3.0,<6.4.0"]
-pyflakes = ["pyflakes>=2.5.0,<3.1.0"]
+autopep8 = ["autopep8>=1.6.0"]
+flake8 = ["flake8>=5.0.0"]
+mccabe = ["mccabe>=0.7.0"]
+pycodestyle = ["pycodestyle>=2.9.0"]
-+pydocstyle = ["pydocstyle>=6.2.0"]
++pydocstyle = ["pydocstyle>=6.3.0"]
+pyflakes = ["pyflakes>=2.5.0"]
pylint = ["pylint>=2.5.0,<3"]
rope = ["rope>1.2.0"]
--yapf = ["yapf", "whatthepatch>=1.0.2,<2.0.0"]
-+yapf = ["yapf", "whatthepatch>=1.0.2"]
+-yapf = ["yapf<=0.32.0", "whatthepatch>=1.0.2,<2.0.0", "toml"]
++yapf = ["yapf<=0.32.0", "whatthepatch>=1.0.2", "toml"]
websockets = ["websockets>=10.3"]
test = [
"pylint>=2.5.0,<3",