aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Hogge <agh@riseup.net>2023-11-16 11:41:07 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2023-11-16 23:40:27 +0000
commit132921c8f898c5ca11780b9b87543cce6eb406d2 (patch)
treeecde1453955282ec4acb88573237e5368b0a015c
parent6a7f9d865b5560b0a7d520553f3d68edafb7b638 (diff)
downloadports-132921c8f898c5ca11780b9b87543cce6eb406d2.tar.gz
ports-132921c8f898c5ca11780b9b87543cce6eb406d2.zip
emulators/wine-devel: GSTREAMER dependency cleanup
* Add missing USES=gnome and USE=GNOME=glib20 for GSTREAMER dependencies * Add ${STRIP_CMD} to GNU configure environment variable ac_cv_prog_STRIP PR: 274953
-rw-r--r--emulators/wine-devel/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index e02736209c96..955d9d87d2c3 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= wine
DISTVERSION= 8.20
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= https://dl.winehq.org/wine/source/8.x/
@@ -52,7 +53,7 @@ CONFIGURE_ARGS+=--verbose \
--without-unwind \
--without-usb \
--without-wayland
-CONFIGURE_ENV= CPPBIN="${CPP}" FLEX="${LOCALBASE}/bin/flex"
+CONFIGURE_ENV= ac_cv_prog_STRIP="${STRIP_CMD}" CPPBIN="${CPP}" FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
@@ -79,7 +80,8 @@ GECKO_DESC= Bundle Gecko MSI package for Wine
MONO_DESC= Bundle Mono MSI package for Wine
ALSA_CONFIGURE_WITH= alsa
-ALSA_USES= gstreamer
+ALSA_USES= gnome gstreamer
+ALSA_USE= GNOME=glib20
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_RUN_DEPENDS= alsa-plugins>0:audio/alsa-plugins
@@ -96,7 +98,8 @@ GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
MONO_RUN_DEPENDS= wine-mono-devel>0:emulators/wine-mono-devel
OSS_CONFIGURE_WITH= oss
-OSS_USES= gstreamer
+OSS_USES= gnome gstreamer
+OSS_USE= GNOME=glib20
V4L_CONFIGURE_WITH= v4l2
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat