aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-10-07 07:27:40 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-10-07 07:27:40 +0000
commit1333140510495670f6f071c9452e2dc56925c342 (patch)
tree4dcd48d5adcf5b572c00e4dcd92c669dc72d3551
parentdbf7dfab863326800c26cb429e1b72ce2133b7ed (diff)
downloadports-1333140510495670f6f071c9452e2dc56925c342.tar.gz
ports-1333140510495670f6f071c9452e2dc56925c342.zip
x11/xfce4-docklike-plugin: Update to 0.4.1
- Remove unneeded dependency - Let GL helper use DISTVERSION as the TAG (removing GL_TAGNAME) - Remove unneeded LDFLAGS - Remove patches now included upstream PR: 273941 Approved by: Quentin Baker <bsd@quentb.com> (maintainer)
-rw-r--r--x11/xfce4-docklike-plugin/Makefile13
-rw-r--r--x11/xfce4-docklike-plugin/distinfo6
-rw-r--r--x11/xfce4-docklike-plugin/files/patch-src_Helpers.cpp11
-rw-r--r--x11/xfce4-docklike-plugin/files/patch-src_Wnck.cpp20
-rw-r--r--x11/xfce4-docklike-plugin/pkg-plist14
5 files changed, 22 insertions, 42 deletions
diff --git a/x11/xfce4-docklike-plugin/Makefile b/x11/xfce4-docklike-plugin/Makefile
index e3fdc3824e43..652c9e6d192f 100644
--- a/x11/xfce4-docklike-plugin/Makefile
+++ b/x11/xfce4-docklike-plugin/Makefile
@@ -1,18 +1,16 @@
PORTNAME= xfce4-docklike-plugin
-PORTVERSION= 0.4.0
-DISTVERSIONPREFIX= ${PORTNAME}
-PORTREVISION= 2
+PORTVERSION= 0.4.1
+DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= x11 xfce
MAINTAINER= bsd@quentb.com
COMMENT= Modern, minimalist taskbar for Xfce
-WWW= https://gitlab.xfce.org/panel-plugins/xfce4-docklike-plugin
+WWW= https://gitlab.xfce.org/panel-plugins/xfce4-docklike-plugin
LICENSE= GPLv3
BUILD_DEPENDS= xdt-csource:devel/xfce4-dev-tools
-LIB_DEPENDS= libinotify.so:devel/libinotify \
- libharfbuzz.so:print/harfbuzz
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
USES= gettext-tools gmake gnome libtool pkgconfig xfce \
xorg
@@ -20,12 +18,10 @@ USES= gettext-tools gmake gnome libtool pkgconfig xfce \
USE_GITLAB= yes
GL_SITE= https://gitlab.xfce.org
GL_ACCOUNT= panel-plugins
-GL_TAGNAME= e6831250e5ca792f31ef4b493b1a92020fe1ab6b
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= autogen.sh
INSTALL_TARGET= install-strip
-LDFLAGS+= -L${LOCALBASE}/lib -linotify
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool libwnck3
USE_XFCE= libmenu panel
@@ -33,6 +29,7 @@ USE_XORG= x11
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
+
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
diff --git a/x11/xfce4-docklike-plugin/distinfo b/x11/xfce4-docklike-plugin/distinfo
index 78fee06ad773..e919902005bb 100644
--- a/x11/xfce4-docklike-plugin/distinfo
+++ b/x11/xfce4-docklike-plugin/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1636859974
-SHA256 (panel-plugins-xfce4-docklike-plugin-e6831250e5ca792f31ef4b493b1a92020fe1ab6b_GL0.tar.gz) = f49144f35a7dcfb172406f43da5a7a374be9d85b1440f18bcf287008f3a2588f
-SIZE (panel-plugins-xfce4-docklike-plugin-e6831250e5ca792f31ef4b493b1a92020fe1ab6b_GL0.tar.gz) = 57088
+TIMESTAMP = 1695108872
+SHA256 (xfce4-docklike-plugin-xfce4-docklike-plugin-0.4.1.tar.bz2) = da5c084058a1c2d7a0403ead5d743f254e5542f27cbf32014663523912a26d09
+SIZE (xfce4-docklike-plugin-xfce4-docklike-plugin-0.4.1.tar.bz2) = 63616
diff --git a/x11/xfce4-docklike-plugin/files/patch-src_Helpers.cpp b/x11/xfce4-docklike-plugin/files/patch-src_Helpers.cpp
deleted file mode 100644
index 738f66863335..000000000000
--- a/x11/xfce4-docklike-plugin/files/patch-src_Helpers.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Helpers.cpp.orig 2021-08-07 07:23:04 UTC
-+++ src/Helpers.cpp
-@@ -83,7 +83,7 @@ namespace Help
- {
- char buffer[1024];
- strcpy(buffer, str.c_str());
-- return basename(buffer);
-+ return g_path_get_basename(buffer);
- }
-
- std::string trim(const std::string str)
diff --git a/x11/xfce4-docklike-plugin/files/patch-src_Wnck.cpp b/x11/xfce4-docklike-plugin/files/patch-src_Wnck.cpp
deleted file mode 100644
index 7a9c64116fd9..000000000000
--- a/x11/xfce4-docklike-plugin/files/patch-src_Wnck.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/Wnck.cpp.orig 2021-08-07 07:23:13 UTC
-+++ src/Wnck.cpp
-@@ -35,7 +35,7 @@ namespace Wnck
- int nbr = read(fd, buffer, 512);
- ::close(fd);
-
-- char* exe = basename(buffer);
-+ char* exe = g_path_get_basename(buffer);
- if (strcmp(exe, "python") != 0) // ADDIT graphical interpreters here
- return exe;
-
-@@ -44,7 +44,7 @@ namespace Wnck
- ;
-
- if (it < buffer + nbr)
-- return basename(it);
-+ return g_path_get_basename(it);
- }
-
- // fallback : return window's name
diff --git a/x11/xfce4-docklike-plugin/pkg-plist b/x11/xfce4-docklike-plugin/pkg-plist
index c37d0f6c7452..1c4d72a91c84 100644
--- a/x11/xfce4-docklike-plugin/pkg-plist
+++ b/x11/xfce4-docklike-plugin/pkg-plist
@@ -1,4 +1,5 @@
lib/xfce4/panel/plugins/libdocklike.so
+%%NLS%%share/locale/bg/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/da/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/de/LC_MESSAGES/xfce4-docklike-plugin.mo
@@ -6,14 +7,27 @@ lib/xfce4/panel/plugins/libdocklike.so
%%NLS%%share/locale/es/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/he/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/id/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/ie/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/it/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-docklike-plugin.mo
%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-docklike-plugin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-docklike-plugin.mo
share/xfce4/panel/plugins/docklike.desktop