aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:20:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:20:18 +0000
commit1424f61415911ed21c038aa0384158e44eedb854 (patch)
treea06499a6e263725bf510ae443c23488d7b5728e4
parentce543cafaff856e272048795da4e2dbfd71c2d5f (diff)
downloadports-1424f61415911ed21c038aa0384158e44eedb854.tar.gz
ports-1424f61415911ed21c038aa0384158e44eedb854.zip
security/py-pyhanko-certvalidator: Update to 0.23.0
-rw-r--r--security/py-pyhanko-certvalidator/Makefile8
-rw-r--r--security/py-pyhanko-certvalidator/distinfo6
-rw-r--r--security/py-pyhanko-certvalidator/files/patch-pyproject.toml12
3 files changed, 20 insertions, 6 deletions
diff --git a/security/py-pyhanko-certvalidator/Makefile b/security/py-pyhanko-certvalidator/Makefile
index c69e151ac381..a9c7dd7cde0f 100644
--- a/security/py-pyhanko-certvalidator/Makefile
+++ b/security/py-pyhanko-certvalidator/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pyhanko-certvalidator
-PORTVERSION= 0.20.1
+PORTVERSION= 0.23.0
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,14 +11,16 @@ WWW= https://github.com/MatthiasValvekens/certvalidator
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=1.5.1:devel/py-asn1crypto@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=3.3.1:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=3.3.1,1:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oscrypto>=1.1.0:security/py-oscrypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.24.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}uritools>=3.0.1:net/py-uritools@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/security/py-pyhanko-certvalidator/distinfo b/security/py-pyhanko-certvalidator/distinfo
index ded8c8b0b063..93253e91a237 100644
--- a/security/py-pyhanko-certvalidator/distinfo
+++ b/security/py-pyhanko-certvalidator/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1681052988
-SHA256 (pyhanko-certvalidator-0.20.1.tar.gz) = 58651ef0486a081b9b6a4117fb6f4d725e71cdf72cfa10f5f7e7426ccbea036e
-SIZE (pyhanko-certvalidator-0.20.1.tar.gz) = 100466
+TIMESTAMP = 1688166318
+SHA256 (pyhanko-certvalidator-0.23.0.tar.gz) = 424d9070e92096ab088ae1bf5b027a0fd6adb48a3b5ff446d53b14d1dbc00338
+SIZE (pyhanko-certvalidator-0.23.0.tar.gz) = 99071
diff --git a/security/py-pyhanko-certvalidator/files/patch-pyproject.toml b/security/py-pyhanko-certvalidator/files/patch-pyproject.toml
new file mode 100644
index 000000000000..515b75d4b5d7
--- /dev/null
+++ b/security/py-pyhanko-certvalidator/files/patch-pyproject.toml
@@ -0,0 +1,12 @@
+--- pyproject.toml.orig 2023-05-14 16:55:10 UTC
++++ pyproject.toml
+@@ -1,7 +1,7 @@
+ [build-system]
+ requires = [
+- "setuptools>=67.4",
+- "wheel", "pytest-runner",
++ "setuptools>=61",
++ "wheel",
+ ]
+ build-backend = "setuptools.build_meta"
+