aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2024-03-19 16:12:07 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2024-03-19 16:12:46 +0000
commit146b99934bee58941565cab519517ce52d167a8e (patch)
tree59064317ea405038659b8dcdb6081c9188c397b2
parent28df2926d2ad90e95a53276b8e0fb4eaccd84245 (diff)
downloadports-146b99934bee58941565cab519517ce52d167a8e.tar.gz
ports-146b99934bee58941565cab519517ce52d167a8e.zip
security/openssh-portable: Update to 9.7p1
-rw-r--r--security/openssh-portable/Makefile10
-rw-r--r--security/openssh-portable/distinfo10
-rw-r--r--security/openssh-portable/files/extra-patch-gssapi-auth2-gss.c8
3 files changed, 10 insertions, 18 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 0fc53a49df7b..ccf46bb23850 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -1,6 +1,6 @@
PORTNAME= openssh
-DISTVERSION= 9.6p1
-PORTREVISION= 2
+DISTVERSION= 9.7p1
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= OPENBSD/OpenSSH/portable
@@ -109,13 +109,13 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-hpn-gss-glue
. endif
# - See https://sources.debian.org/data/main/o/openssh/ for which subdir to
# pull from.
-GSSAPI_DEBIAN_VERSION= 9.6p1
-GSSAPI_DEBIAN_SUBDIR= ${GSSAPI_DEBIAN_VERSION:U${DISTVERSION}}-3
+GSSAPI_DEBIAN_VERSION= 9.7p1
+GSSAPI_DEBIAN_SUBDIR= ${GSSAPI_DEBIAN_VERSION:U${DISTVERSION}}-2
# - Debian does not use a versioned filename so we trick fetch to make one for
# us with the ?<anything>=/ trick.
PATCH_SITES+= https://sources.debian.org/data/main/o/openssh/1:${GSSAPI_DEBIAN_SUBDIR}/debian/patches/gssapi.patch?dummy=/:gsskex
# Bump this when updating the patch location
-GSSAPI_DISTVERSION= 9.4p1
+GSSAPI_DISTVERSION= 9.7p1
PATCHFILES+= openssh-${GSSAPI_DISTVERSION:U${DISTVERSION}}-gsskex-all-debian-rh-${GSSAPI_DISTVERSION}.patch:-p1:gsskex
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gssapi-auth2-gss.c
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gssapi-kexgssc.c
diff --git a/security/openssh-portable/distinfo b/security/openssh-portable/distinfo
index 72841b271ab9..6d5d064d68be 100644
--- a/security/openssh-portable/distinfo
+++ b/security/openssh-portable/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1706059638
-SHA256 (openssh-9.6p1.tar.gz) = 910211c07255a8c5ad654391b40ee59800710dd8119dd5362de09385aa7a777c
-SIZE (openssh-9.6p1.tar.gz) = 1857862
-SHA256 (openssh-9.4p1-gsskex-all-debian-rh-9.4p1.patch) = 03a32678a96cfd274482378d0d2889709018c403e40207b8d5dca41b7e9941bd
-SIZE (openssh-9.4p1-gsskex-all-debian-rh-9.4p1.patch) = 131920
+TIMESTAMP = 1710784635
+SHA256 (openssh-9.7p1.tar.gz) = 490426f766d82a2763fcacd8d83ea3d70798750c7bd2aff2e57dc5660f773ffd
+SIZE (openssh-9.7p1.tar.gz) = 1848766
+SHA256 (openssh-9.7p1-gsskex-all-debian-rh-9.7p1.patch) = 30d9652a18851c0b7a80b8f07d70adc3a77267b656f784c9e89cb93171f22210
+SIZE (openssh-9.7p1-gsskex-all-debian-rh-9.7p1.patch) = 131397
diff --git a/security/openssh-portable/files/extra-patch-gssapi-auth2-gss.c b/security/openssh-portable/files/extra-patch-gssapi-auth2-gss.c
index 3f9694c8d466..68170a9f8e79 100644
--- a/security/openssh-portable/files/extra-patch-gssapi-auth2-gss.c
+++ b/security/openssh-portable/files/extra-patch-gssapi-auth2-gss.c
@@ -9,11 +9,3 @@
{
Authctxt *authctxt = ssh->authctxt;
int r, authenticated = 0;
-@@ -373,6 +373,7 @@ input_gssapi_mic(int type, u_int32_t plen, struct ssh
-
- Authmethod method_gsskeyex = {
- "gssapi-keyex",
-+ NULL,
- userauth_gsskeyex,
- &options.gss_authentication
- };