aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-26 00:05:53 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-26 00:05:53 +0000
commit159b44b2fb70889722fbf810f22aea435848684d (patch)
tree8188a06ca6489d0d5bd0e720e27e332448e83ced
parent0ca254d63aed1c4238d6fd998c6933287444f474 (diff)
downloadports-159b44b2fb70889722fbf810f22aea435848684d.tar.gz
ports-159b44b2fb70889722fbf810f22aea435848684d.zip
audio/jack: fix build on powerpc and powerpc64
Use GCC: 09:13:58 runner ['c++', '-O2', '-pipe', '-fPIC', '-fstack-protector-strong', '-fno-strict-aliasing', '-Wall', '-Wno-invalid-offsetof', '-std=gnu++11', '-fPIC', '-Ifreebsd', '-I../freebsd', '-Iposix', '-I../posix', '-Icommon', '-I../common', '-Icommon/jack', '-I../common/jack', '-I.', '-I..', '-I../compat/alloca', '-I/usr/local/include/opus', '-I/usr/local/include', '-I/usr/local/include/dbus-1.0', '-I/usr/local/lib/dbus-1.0/include', '-DEXECINFO=1', '-DHAVE_LIBSYSINFO=1', '-DHAVE_DOXYGEN=0', '-DHAVE_ALSA=0', '-DHAVE_FIREWIRE=0', '-DHAVE_IIO=0', '-DHAVE_PORTAUDIO=0', '-DHAVE_WINMME=0', '-DHAVE_CELT=0', '-DHAVE_EXAMPLE_TOOLS=0', '-DHAVE_OPUS_OPUS_CUSTOM_H=1', '-DHAVE_OPUS_PKG=1', '-DHAVE_OPUS=1', '-DHAVE_SAMPLERATE=1', '-DHAVE_SNDFILE=0', '-DHAVE_READLINE=0', '-DHAVE_SYSTEMD=0', '-DHAVE_DB_H=1', '-DHAVE_DB=0', '-DHAVE_ZALSA=0', '-DHAVE_PPOLL=1', '-DHAVE_EXECINFO_H=1', '-DJACK_VERSION="[]"', '-DHAVE_DBUS_1=1', '-DHAVE_EXPAT=1', '-DUSE_LIBDBUS_AUTOLAUNCH=1', '-DCLIENT_NUM=256', '-DPORT_NUM_FOR_CLIENT=2048', '-DADDON_DIR="/usr/local/lib/jack"', '-DJACK_LOCATION="/usr/local/bin"', '-DUSE_POSIX_SHM=1', '-DJACKMP=1', '-DJACK_DBUS=1', '-DHAVE_CONFIG_H', '-DSERVER_SIDE', '../common/JackDebugClient.cpp', '-c', '-o/wrkdirs/usr/ports/audio/jack/work/jack2-1.9.20/build/common/JackDebugClient.cpp.2.o', '-I/usr/local/include'] In file included from ../common/JackDebugClient.cpp:21: ../common/JackEngineControl.h:67:5: error: requested alignment is less than minimum alignment of 8 for type 'Jack::JackTransportEngine' alignas(UInt32) JackTransportEngine fTransport; ^ ../common/JackEngineControl.h:89:5: error: requested alignment is less than minimum alignment of 8 for type 'Jack::JackFrameTimer' alignas(UInt32) JackFrameTimer fFrameTimer; ^ 2 errors generated.
-rw-r--r--audio/jack/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index c33166d1df5d..c655e2d00868 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -12,7 +12,7 @@ LICENSE_COMB= multi
LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libsysinfo.so:devel/libsysinfo
-USES= compiler:c11 pkgconfig python:3.4+ shebangfix waf
+USES= pkgconfig python:3.4+ shebangfix waf
USE_LDCONFIG= yes
USE_RC_SUBR= jackd
@@ -49,6 +49,14 @@ OPUS_CONFIGURE_OFF= --opus=no
PROFILING_DESC= Build with profiling information
PROFILING_CONFIGURE_ON= --profile
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc || ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c11
+.endif
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDBUS}