aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-08-07 09:55:00 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-08-07 09:55:00 +0000
commit15cc5bd5f7e07791137683480cfc174f2d155919 (patch)
tree25e62fc44deaf43df867b7b5fd558268d7e94b0c
parent67750f70094193b7ff6f7d6d4a0d39a71ed0d1a8 (diff)
downloadports-15cc5bd5f7e07791137683480cfc174f2d155919.tar.gz
ports-15cc5bd5f7e07791137683480cfc174f2d155919.zip
sysutils/ansible-sshjail: Update to latest commit
Update to latest upstream commit which includes fixes to allow it to work with recent ansible releases. Remove homegrown patch superseded by upstream commits.
-rw-r--r--sysutils/ansible-sshjail/Makefile5
-rw-r--r--sysutils/ansible-sshjail/distinfo6
-rw-r--r--sysutils/ansible-sshjail/files/patch-sshjail.py94
3 files changed, 5 insertions, 100 deletions
diff --git a/sysutils/ansible-sshjail/Makefile b/sysutils/ansible-sshjail/Makefile
index 698d0a95cf34..e0bf03dfcaa3 100644
--- a/sysutils/ansible-sshjail/Makefile
+++ b/sysutils/ansible-sshjail/Makefile
@@ -1,8 +1,7 @@
PORTNAME= ansible-sshjail
DISTVERSIONPREFIX= v
-DISTVERSION= 1.1.0-30
-PORTREVISION= 2
-DISTVERSIONSUFFIX= -g981674f
+DISTVERSION= 1.1.0-35
+DISTVERSIONSUFFIX= -g35c3bf6
CATEGORIES= sysutils
MAINTAINER= madpilot@FreeBSD.org
diff --git a/sysutils/ansible-sshjail/distinfo b/sysutils/ansible-sshjail/distinfo
index 678df5f2bb31..b4c06a1e174b 100644
--- a/sysutils/ansible-sshjail/distinfo
+++ b/sysutils/ansible-sshjail/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1618521706
-SHA256 (austinhyde-ansible-sshjail-v1.1.0-30-g981674f_GH0.tar.gz) = 357f212cf1b34c03cee436e963b09003be73ef69db216907b93722881b0a9781
-SIZE (austinhyde-ansible-sshjail-v1.1.0-30-g981674f_GH0.tar.gz) = 10702
+TIMESTAMP = 1628281322
+SHA256 (austinhyde-ansible-sshjail-v1.1.0-35-g35c3bf6_GH0.tar.gz) = af7da24370e00d7cbc96b7b6873dd7f833b9ccc3b882927c7e12df60ee9fb714
+SIZE (austinhyde-ansible-sshjail-v1.1.0-35-g35c3bf6_GH0.tar.gz) = 10896
diff --git a/sysutils/ansible-sshjail/files/patch-sshjail.py b/sysutils/ansible-sshjail/files/patch-sshjail.py
deleted file mode 100644
index e27ec1ad5eef..000000000000
--- a/sysutils/ansible-sshjail/files/patch-sshjail.py
+++ /dev/null
@@ -1,94 +0,0 @@
-From bcb0a961df77a0d7a3b2e7e58fac3e283b5ef8c4 Mon Sep 17 00:00:00 2001
-From: Mohamad Safadieh <self@mhmd.sh>
-Date: Wed, 5 May 2021 12:38:26 -0400
-Subject: [PATCH] added sshpass_prompt, ssh_transfer_method, timeout
-
---- sshjail.py.orig 2021-01-07 19:31:49 UTC
-+++ sshjail.py
-@@ -49,6 +49,17 @@ DOCUMENTATION = '''
- vars:
- - name: ansible_password
- - name: ansible_ssh_pass
-+ sshpass_prompt:
-+ description: Password prompt that sshpass should search for. Supported by sshpass 1.06 and up
-+ default: ''
-+ ini:
-+ - section: 'ssh_connection'
-+ key: 'sshpass_prompt'
-+ env:
-+ - name: ANSIBLE_SSHPASS_PROMPT
-+ vars:
-+ - name: ansible_sshpass_prompt
-+ version_added: '2.10'
- ssh_args:
- description: Arguments to pass to all ssh cli tools
- default: '-C -o ControlMaster=auto -o ControlPersist=60s'
-@@ -140,10 +151,9 @@ DOCUMENTATION = '''
- - key: ssh_extra_args
- section: ssh_connection
- version_added: '2.7'
-- retries:
-- # constant: ANSIBLE_SSH_RETRIES
-+ reconnection_retries:
- description: Number of attempts to connect.
-- default: 3
-+ default: 0
- type: integer
- env:
- - name: ANSIBLE_SSH_RETRIES
-@@ -153,8 +163,8 @@ DOCUMENTATION = '''
- - section: ssh_connection
- key: retries
- vars:
-- - name: ansible_ssh_retries
-- version_added: '2.7'
-+ - name: ansible_ssh_retries
-+ version_added: '2.7'
- port:
- description: Remote port to connect to.
- type: int
-@@ -247,6 +257,16 @@ DOCUMENTATION = '''
- vars:
- - name: ansible_sftp_batch_mode
- version_added: '2.7'
-+ ssh_transfer_method:
-+ default: smart
-+ description:
-+ - "Preferred method to use when transferring files over ssh"
-+ - Setting to 'smart' (default) will try them in order, until one succeeds or they all fail
-+ - Using 'piped' creates an ssh pipe with ``dd`` on either side to copy the data
-+ choices: ['sftp', 'scp', 'piped', 'smart']
-+ env: [{name: ANSIBLE_SSH_TRANSFER_METHOD}]
-+ ini:
-+ - {key: transfer_method, section: ssh_connection}
- scp_if_ssh:
- default: smart
- description:
-@@ -270,6 +290,27 @@ DOCUMENTATION = '''
- vars:
- - name: ansible_ssh_use_tty
- version_added: '2.7'
-+ timeout:
-+ default: 10
-+ description:
-+ - This is the default ammount of time we will wait while establishing an ssh connection
-+ - It also controls how long we can wait to access reading the connection once established (select on the socket)
-+ env:
-+ - name: ANSIBLE_TIMEOUT
-+ - name: ANSIBLE_SSH_TIMEOUT
-+ version_added: '2.11'
-+ ini:
-+ - key: timeout
-+ section: defaults
-+ - key: timeout
-+ section: ssh_connection
-+ version_added: '2.11'
-+ vars:
-+ - name: ansible_ssh_timeout
-+ version_added: '2.11'
-+ cli:
-+ - name: timeout
-+ type: integer
- '''
-
- try: